summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-16 09:27:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-16 09:27:43 +0000
commitf423a29ca7abb5fcfbae57fefdb90459b92b83f2 (patch)
tree785444f1f6f5459ff3967986964a6bd7753f76df /media-video
parentStabilise latest on amd64 and x86. Drop older. (diff)
downloadhistorical-f423a29ca7abb5fcfbae57fefdb90459b92b83f2.tar.gz
historical-f423a29ca7abb5fcfbae57fefdb90459b92b83f2.tar.bz2
historical-f423a29ca7abb5fcfbae57fefdb90459b92b83f2.zip
Remove versions I was unable to build.
Package-Manager: portage-2.2.0_alpha105/cvs/Linux x86_64
Diffstat (limited to 'media-video')
-rw-r--r--media-video/miro/ChangeLog11
-rw-r--r--media-video/miro/files/4.0.1-ffmpeg.patch95
-rw-r--r--media-video/miro/files/miro-2.5.3-disable-xine-hack.patch16
-rw-r--r--media-video/miro/files/miro-2.5.3-dont-install-test-files.patch37
-rw-r--r--media-video/miro/files/miro-2.5.3-fix-debug.patch12
-rw-r--r--media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch74
-rw-r--r--media-video/miro/files/miro-2.5.3-remove-unittest-option.patch12
-rw-r--r--media-video/miro/miro-4.0.1-r1.ebuild92
-rw-r--r--media-video/miro/miro-4.0.1.ebuild86
9 files changed, 10 insertions, 425 deletions
diff --git a/media-video/miro/ChangeLog b/media-video/miro/ChangeLog
index c2c9f3bf8869..139523798e29 100644
--- a/media-video/miro/ChangeLog
+++ b/media-video/miro/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/miro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/miro/ChangeLog,v 1.14 2012/02/16 19:43:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/miro/ChangeLog,v 1.15 2012/05/16 09:27:42 scarabeus Exp $
+
+ 16 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> -files/4.0.1-ffmpeg.patch,
+ -files/miro-2.5.3-disable-xine-hack.patch,
+ -files/miro-2.5.3-dont-install-test-files.patch,
+ -files/miro-2.5.3-fix-debug.patch,
+ -files/miro-2.5.3-remove-pkg-config-list-all.patch,
+ -files/miro-2.5.3-remove-unittest-option.patch, -miro-4.0.1-r1.ebuild,
+ -miro-4.0.1.ebuild:
+ Remove versions I was unable to build.
*miro-4.0.6 (16 Feb 2012)
diff --git a/media-video/miro/files/4.0.1-ffmpeg.patch b/media-video/miro/files/4.0.1-ffmpeg.patch
deleted file mode 100644
index edf3784591ec..000000000000
--- a/media-video/miro/files/4.0.1-ffmpeg.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-diff -urN miro-4.0.old/linux/miro-segmenter.c miro-4.0/linux/miro-segmenter.c
---- miro-4.0.old/linux/miro-segmenter.c 2011-05-25 15:58:21.000000000 +0200
-+++ miro-4.0/linux/miro-segmenter.c 2011-05-25 16:09:41.000000000 +0200
-@@ -60,7 +60,7 @@
- }
-
- switch (input_codec_context->codec_type) {
-- case CODEC_TYPE_AUDIO:
-+ case AVMEDIA_TYPE_AUDIO:
- output_codec_context->channel_layout = input_codec_context->channel_layout;
- output_codec_context->sample_rate = input_codec_context->sample_rate;
- output_codec_context->channels = input_codec_context->channels;
-@@ -72,7 +72,7 @@
- output_codec_context->block_align = input_codec_context->block_align;
- }
- break;
-- case CODEC_TYPE_VIDEO:
-+ case AVMEDIA_TYPE_VIDEO:
- output_codec_context->pix_fmt = input_codec_context->pix_fmt;
- output_codec_context->width = input_codec_context->width;
- output_codec_context->height = input_codec_context->height;
-@@ -154,7 +154,7 @@
- exit(1);
- }
-
-- ofmt = guess_format("mpegts", NULL, NULL);
-+ ofmt = av_guess_format("mpegts", NULL, NULL);
- if (!ofmt) {
- fprintf(stderr, "Could not find MPEG-TS muxer\n");
- exit(1);
-@@ -174,12 +174,12 @@
-
- for (i = 0; i < ic->nb_streams && (video_index < 0 || audio_index < 0); i++) {
- switch (ic->streams[i]->codec->codec_type) {
-- case CODEC_TYPE_VIDEO:
-+ case AVMEDIA_TYPE_VIDEO:
- video_index = i;
- ic->streams[i]->discard = AVDISCARD_NONE;
- video_st = add_output_stream(oc, ic->streams[i]);
- break;
-- case CODEC_TYPE_AUDIO:
-+ case AVMEDIA_TYPE_AUDIO:
- audio_index = i;
- ic->streams[i]->discard = AVDISCARD_NONE;
- audio_st = add_output_stream(oc, ic->streams[i]);
-@@ -195,7 +195,7 @@
- exit(1);
- }
-
-- dump_format(oc, 0, input, 1);
-+ av_dump_format(oc, 0, input, 1);
-
- if (video_st) {
- codec = avcodec_find_decoder(video_st->codec->codec_id);
-@@ -208,7 +208,7 @@
- }
- }
-
-- if (url_fopen(&oc->pb, output_filename, URL_WRONLY) < 0) {
-+ if (avio_open(&oc->pb, output_filename, URL_WRONLY) < 0) {
- fprintf(stderr, "Could not open '%s'\n", output_filename);
- exit(1);
- }
-@@ -234,7 +234,7 @@
- break;
- }
-
-- if (packet.stream_index == video_index && (packet.flags & PKT_FLAG_KEY)) {
-+ if (packet.stream_index == video_index && (packet.flags & AV_PKT_FLAG_KEY)) {
- segment_time = (double)video_st->pts.val * video_st->time_base.num / video_st->time_base.den;
- }
- else if (video_index < 0) {
-@@ -245,10 +245,10 @@
- }
-
- if (segment_time - prev_segment_time >= segment_duration) {
-- put_flush_packet(oc->pb);
-- url_fclose(oc->pb);
-+ avio_flush(oc->pb);
-+ avio_close(oc->pb);
-
-- if (url_fopen(&oc->pb, output_filename, URL_WRONLY) < 0) {
-+ if (avio_open(&oc->pb, output_filename, URL_WRONLY) < 0) {
- fprintf(stderr, "Could not open '%s'\n", output_filename);
- break;
- }
-@@ -278,7 +278,7 @@
- av_freep(&oc->streams[i]);
- }
-
-- url_fclose(oc->pb);
-+ avio_close(oc->pb);
- av_free(oc);
-
- return 0;
diff --git a/media-video/miro/files/miro-2.5.3-disable-xine-hack.patch b/media-video/miro/files/miro-2.5.3-disable-xine-hack.patch
deleted file mode 100644
index ab0502f325ce..000000000000
--- a/media-video/miro/files/miro-2.5.3-disable-xine-hack.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-# This patch comes from Debian
-# This seems to cause segfaults with newer libxine (?) releases, so disable it.
-# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512719
-# http://bugzilla.pculture.org/show_bug.cgi?id=11263
-
---- platform/gtk-x11/plat/options.py.orig 2009-07-24 15:11:34.000000000 +0200
-+++ platform/gtk-x11/plat/options.py 2009-07-24 15:11:42.000000000 +0200
-@@ -51,7 +51,7 @@
- help="Which renderer to use. (gstreamer, xine)" )
-
- USE_XINE_XV_HACK = GTKPref(key="UseXineXVHack",
-- default=True,
-+ default=False,
- alias="xine-xvhack",
- help="Whether or not to use the Xine xv hack. (true, false)" )
-
diff --git a/media-video/miro/files/miro-2.5.3-dont-install-test-files.patch b/media-video/miro/files/miro-2.5.3-dont-install-test-files.patch
deleted file mode 100644
index 3c7a99f345b8..000000000000
--- a/media-video/miro/files/miro-2.5.3-dont-install-test-files.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- setup.py.old 2009-10-29 12:36:58.000000000 +0100
-+++ setup.py 2009-10-29 12:37:56.000000000 +0100
-@@ -175,7 +175,6 @@
- portable_xpcom_dir = os.path.join(portable_frontend_dir, 'widgets', 'gtk',
- 'xpcom')
- dl_daemon_dir = os.path.join(portable_dir, 'dl_daemon')
--test_dir = os.path.join(portable_dir, 'test')
- resource_dir = os.path.join(root_dir, 'resources')
- platform_dir = os.path.join(root_dir, 'platform', 'gtk-x11')
- platform_package_dir = os.path.join(platform_dir, 'plat')
-@@ -645,9 +644,7 @@
- if os.path.basename(f) != 'app.config.template']
- data_files.append(('/usr/share/miro/resources/', files))
- # handle the sub directories.
--for dir in ('searchengines', 'images', 'testdata',
-- os.path.join('testdata', 'stripperdata'),
-- os.path.join('testdata', 'locale', 'fr', 'LC_MESSAGES')):
-+for dir in ('searchengines', 'images'):
- source_dir = os.path.join(resource_dir, dir)
- dest_dir = os.path.join('/usr/share/miro/resources/', dir)
- data_files.append((dest_dir, listfiles(source_dir)))
-@@ -867,7 +864,6 @@
- packages = [
- 'miro',
- 'miro.dl_daemon',
-- 'miro.test',
- 'miro.dl_daemon.private',
- 'miro.frontends',
- 'miro.frontends.cli',
-@@ -881,7 +877,6 @@
- ],
- package_dir = {
- 'miro': portable_dir,
-- 'miro.test': test_dir,
- 'miro.plat': platform_package_dir,
- },
- cmdclass = {
diff --git a/media-video/miro/files/miro-2.5.3-fix-debug.patch b/media-video/miro/files/miro-2.5.3-fix-debug.patch
deleted file mode 100644
index 460471b51fb3..000000000000
--- a/media-video/miro/files/miro-2.5.3-fix-debug.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-This patch comes from Debian
---- platform/gtk-x11/setup.py.orig 2009-02-28 17:29:13.000000000 +0100
-+++ platform/gtk-x11/setup.py 2009-02-28 17:29:26.000000000 +0100
-@@ -330,7 +330,7 @@
- exit;
- fi
-
-- %(runtimelib)s$GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
-+ %(runtimelib)s$GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON /usr/bin/miro.real --sync "$@"
- else
- %(runtimelib)smiro.real "$@"
- fi
diff --git a/media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch b/media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch
deleted file mode 100644
index 569c68af663e..000000000000
--- a/media-video/miro/files/miro-2.5.3-remove-pkg-config-list-all.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From b5acbb41f5c6b2c4ce3b4a6944459ea425d7f971 Mon Sep 17 00:00:00 2001
-From: Mounir Lamouri (volkmar) <mounir.lamouri@gmail.com>
-Date: Sat, 28 Nov 2009 14:39:19 +0100
-Subject: [PATCH] Remove use of 'pkg-config --list-all' to 'pkg-config --exists'.
- Fix bug 4613.
-
----
- platform/gtk-x11/setup.py | 23 +++++++++++++----------
- 1 files changed, 13 insertions(+), 10 deletions(-)
-
-diff --git a/platform/gtk-x11/setup.py b/platform/gtk-x11/setup.py
-index a731ff6..94dc72a 100755
---- a/platform/gtk-x11/setup.py
-+++ b/platform/gtk-x11/setup.py
-@@ -297,6 +297,14 @@ def parse_pkg_config(command, components, options_dict = None):
-
- return options_dict
-
-+def package_exist(package_name):
-+ """
-+ Return True if the package is present in the system. False otherwise.
-+ The check is made with pkg-config.
-+ """
-+ # pkg-config returs 0 if the package is present
-+ return subprocess.call(['pkg-config', '--exists', package_name]) == 0
-+
- def compile_xine_extractor():
- rv = os.system("gcc %s -o %s `pkg-config --libs --cflags gdk-pixbuf-2.0 glib-2.0 libxine`" %
- (os.path.join(platform_dir, "xine/xine_extractor.c"), os.path.join(platform_dir, "xine/xine_extractor")))
-@@ -346,11 +354,6 @@ fi
-
- #### MozillaBrowser Extension ####
- def get_mozilla_stuff():
-- try:
-- packages = get_command_output("pkg-config --list-all")
-- except RuntimeError, error:
-- sys.exit("Package config error:\n%s" % (error,))
--
- if XPCOM_LIB and GTKMOZEMBED_LIB and XULRUNNER_19 != None:
- print "\nUsing XPCOM_LIB, GTKMOZEMBED_LIB and XULRUNNER_19 values...."
- xulrunner19 = XULRUNNER_19
-@@ -360,24 +363,24 @@ def get_mozilla_stuff():
- else:
- print "\nTrying to figure out xpcom_lib, gtkmozembed_lib, and xulrunner_19 values...."
- xulrunner19 = False
-- if re.search("^libxul", packages, re.MULTILINE):
-+ if package_exist('libxul'):
- xulrunner19 = True
- xpcom_lib = 'libxul'
- gtkmozembed_lib = 'libxul'
-
-- elif re.search("^xulrunner-xpcom", packages, re.MULTILINE):
-+ elif package_exist('xulrunner-xpcom'):
- xpcom_lib = 'xulrunner-xpcom'
- gtkmozembed_lib = 'xulrunner-gtkmozembed'
-
-- elif re.search("^seamonkey-xpcom", packages, re.MULTILINE):
-+ elif package_exist('seamonkey-xpcom'):
- xpcom_lib = 'seamonkey-xpcom'
- gtkmozembed_lib = 'seamonkey-gtkmozembed'
-
-- elif re.search("^mozilla-xpcom", packages, re.MULTILINE):
-+ elif package_exist('mozilla-xpcom'):
- xpcom_lib = 'mozilla-xpcom'
- gtkmozembed_lib = 'mozilla-gtkmozembed'
-
-- elif re.search("^firefox-xpcom", packages, re.MULTILINE):
-+ elif package_exist('firefox-xpcom'):
- xpcom_lib = 'firefox-xpcom'
- gtkmozembed_lib = 'firefox-gtkmozembed'
-
---
-1.6.3.3
-
diff --git a/media-video/miro/files/miro-2.5.3-remove-unittest-option.patch b/media-video/miro/files/miro-2.5.3-remove-unittest-option.patch
deleted file mode 100644
index 79e1e9c604a7..000000000000
--- a/media-video/miro/files/miro-2.5.3-remove-unittest-option.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- miro.real.old 2009-10-29 12:33:29.000000000 +0100
-+++ miro.real 2009-10-29 12:33:43.000000000 +0100
-@@ -81,9 +81,6 @@
- group.add_option('--debug',
- action="store_true",
- help='Starts Miro in a gdb session for better debugging.')
--group.add_option('--unittest',
-- dest='unittest', action='store_true',
-- help='Run unittests instead of launching the program.')
- parser.set_defaults(unittest=False)
- group.add_option('--profile',
- metavar='<FILE>',
diff --git a/media-video/miro/miro-4.0.1-r1.ebuild b/media-video/miro/miro-4.0.1-r1.ebuild
deleted file mode 100644
index 119c0a9a4bf6..000000000000
--- a/media-video/miro/miro-4.0.1-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/miro/miro-4.0.1-r1.ebuild,v 1.2 2012/01/29 02:22:11 floppym Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2:2.7"
-PYTHON_USE_WITH="sqlite"
-inherit eutils fdo-mime gnome2-utils distutils
-
-DESCRIPTION="Open source video player and podcast client"
-HOMEPAGE="http://www.getmiro.com/"
-SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="libnotify aac musepack xvid"
-
-CDEPEND="
- dev-libs/glib:2
- >=dev-python/pyrex-0.9.6.4
- dev-python/pygtk:2
- dev-python/pygobject:2
- >=virtual/ffmpeg-0.6.90"
-
-RDEPEND="${CDEPEND}
- dev-python/dbus-python
- dev-python/pycairo
- dev-python/gconf-python
- dev-python/gst-python:0.10
- dev-python/pyrex
- >=dev-python/pywebkitgtk-1.1.5
- dev-python/pycurl
- >=net-libs/rb_libtorrent-0.14.1[python]
- media-libs/mutagen
- media-plugins/gst-plugins-meta:0.10
- media-plugins/gst-plugins-pango:0.10
- aac? ( media-plugins/gst-plugins-faad:0.10 )
- libnotify? ( dev-python/notify-python )
- musepack? ( media-plugins/gst-plugins-musepack:0.10 )
- xvid? ( media-plugins/gst-plugins-xvid:0.10 )"
-
-DEPEND="${CDEPEND}"
-
-S="${WORKDIR}/${P}/linux"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-ffmpeg.patch"
- distutils_src_prepare
-}
-
-src_install() {
- # doing the mv now otherwise, distutils_src_install will install it
- mv README README.gtk || die "mv failed"
-
- distutils_src_install
-
- # installing docs
- dodoc README.gtk ../{CREDITS,README} || die "dodoc failed"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-
- ewarn
- ewarn "If miro doesn't play some video or audio format, please"
- ewarn "check your USE flags on media-plugins/gst-plugins-meta"
- ewarn
- elog "Miro for Linux doesn't support Adobe Flash, therefore you"
- elog "you will not see any embedded video player on MiroGuide."
- elog
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-}
diff --git a/media-video/miro/miro-4.0.1.ebuild b/media-video/miro/miro-4.0.1.ebuild
deleted file mode 100644
index ce5d3182d877..000000000000
--- a/media-video/miro/miro-4.0.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/miro/miro-4.0.1.ebuild,v 1.3 2012/01/29 02:22:11 floppym Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2:2.7"
-PYTHON_USE_WITH="sqlite"
-inherit eutils fdo-mime gnome2-utils distutils
-
-DESCRIPTION="Open source video player and podcast client"
-HOMEPAGE="http://www.getmiro.com/"
-SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="libnotify aac musepack xvid"
-
-CDEPEND="
- dev-libs/glib:2
- >=dev-python/pyrex-0.9.6.4
- dev-python/pygtk:2
- dev-python/pygobject:2
- >=virtual/ffmpeg-0.6.90"
-
-RDEPEND="${CDEPEND}
- dev-python/dbus-python
- dev-python/pycairo
- dev-python/gconf-python
- dev-python/gst-python:0.10
- >=dev-python/pywebkitgtk-1.1.5
- dev-python/pycurl
- >=net-libs/rb_libtorrent-0.14.1[python]
- media-libs/mutagen
- media-plugins/gst-plugins-meta:0.10
- media-plugins/gst-plugins-pango:0.10
- aac? ( media-plugins/gst-plugins-faad:0.10 )
- libnotify? ( dev-python/notify-python )
- musepack? ( media-plugins/gst-plugins-musepack:0.10 )
- xvid? ( media-plugins/gst-plugins-xvid:0.10 )"
-
-DEPEND="${CDEPEND}"
-
-S="${WORKDIR}/${P}/linux"
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-ffmpeg.patch"
- distutils_src_prepare
-}
-
-src_install() {
- # doing the mv now otherwise, distutils_src_install will install it
- mv README README.gtk || die "mv failed"
-
- distutils_src_install
-
- # installing docs
- dodoc README.gtk ../{CREDITS,README} || die "dodoc failed"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-
- ewarn
- ewarn "If miro doesn't play some video or audio format, please"
- ewarn "check your USE flags on media-plugins/gst-plugins-meta"
- ewarn
- elog "Miro for Linux doesn't support Adobe Flash, therefore you"
- elog "you will not see any embedded video player on MiroGuide."
- elog
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-}