summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-29 15:05:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-29 15:05:59 +0000
commite3d7667bca679fe36fa48cc39d31536ff92eebd2 (patch)
tree3c264920e9beaf21e50950f4dfa1fe1e5c34157a /net-analyzer/fe3d/files
parentMarked ~ppc (bug #305781). (diff)
downloadhistorical-e3d7667bca679fe36fa48cc39d31536ff92eebd2.tar.gz
historical-e3d7667bca679fe36fa48cc39d31536ff92eebd2.tar.bz2
historical-e3d7667bca679fe36fa48cc39d31536ff92eebd2.zip
Fix building with -Wl,--as-needed wrt #277794 by Kacper Kowalik.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/fe3d/files')
-rw-r--r--net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch b/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch
new file mode 100644
index 000000000000..5399da4b8e97
--- /dev/null
+++ b/net-analyzer/fe3d/files/fe3d-0.11.2-asneeded.patch
@@ -0,0 +1,39 @@
+--- configure.ac
++++ configure.ac
+@@ -46,16 +46,15 @@
+ ])
+ fi
+
+-CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
+-CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
+-CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
+-LIBS="$LIBS $WX_LIBS"
++#CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
++#CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
++#CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
++#LIBS="$LIBS $WX_LIBS"
+
+ AM_CPPFLAGS="$AM_CPPFLAGS $GL_CFLAGS $GLU_CFLAGS"
+-AM_LDFLAGS="$AM_LDFLAGS $GL_LIBS $GLU_LIBS"
+ AC_SUBST([AM_CPPFLAGS])
+ AC_SUBST([AM_LDFLAGS])
+-AC_SUBST([$PREFIX])
++#AC_SUBST([$PREFIX])
+
+ AC_OUTPUT
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,8 +1,10 @@
+-fe3d_CPPFLAGS = -DFE_DATA_DIR="\"@datadir@/@PACKAGE@/\""
++fe3d_CPPFLAGS = -DFE_DATA_DIR="\"@datadir@/@PACKAGE@/\"" @WX_CPPFLAGS@
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src/include
+ bin_PROGRAMS = fe3d
+ fe3d_SOURCES = fe_config.cpp fe_core.cpp fe_draw.cpp fe_events.cpp fe_host.cpp fe_hosts.cpp fe_match.cpp fe_node.cpp fe_os_rgx.cpp fe_port.cpp fe_root_node.cpp fe_tools.cpp geo_cache.cpp gl_util.cpp libfe3d.cpp nmap_parser.cpp tex_cache.cpp wxfe3d_app.cpp wxfe3d_frame.cpp wxfe3d_glcanvas.cpp ui_nmap_ctrl.cpp ./gui/fe3d_ui.cpp ./regexp/Matcher.cpp ./regexp/Pattern.cpp ./regexp/WCMatcher.cpp ./regexp/WCPattern.cpp
+-
++fe3d_CFLAGS = @WX_CFLAGS@
++fe3d_CXXFLAGS = @WX_CXXFLAGS_ONLY@
++fe3d_LDADD = @GLU_LIBS@ @WX_LIBS@
+ fe3ddir = @datadir@/@PACKAGE@
+ fe3d_imgdir = @datadir@/@PACKAGE@/img
+ fe3d_DATA = $(top_srcdir)/data/*