summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-07-01 17:20:31 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-07-01 17:20:31 +0000
commitb7b161fe19ac7001c3afaa2dab0d8a6f71c78708 (patch)
treeb45b35f26d9535f84106225f7d675802f9d12009 /net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild
parentFix for JAVA_PKG_FORCE_COMPILER. exports JAVA and JAVAC now. (diff)
downloadhistorical-b7b161fe19ac7001c3afaa2dab0d8a6f71c78708.tar.gz
historical-b7b161fe19ac7001c3afaa2dab0d8a6f71c78708.tar.bz2
historical-b7b161fe19ac7001c3afaa2dab0d8a6f71c78708.zip
1.1 version bump for bug 138734. Thanks to Taku Murakami <murakami.taku at gmail dot com>. Also using tc-getCC instead of gcc hardcoded by Makefile.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild')
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild
new file mode 100644
index 000000000000..a1f17c648823
--- /dev/null
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fwlogwatch/fwlogwatch-1.1.ebuild,v 1.1 2006/07/01 17:20:31 vanquirius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A packet filter and firewall log analyzer"
+HOMEPAGE="http://fwlogwatch.inside-security.de/"
+SRC_URI="http://www.kybs.de/boris/sw/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/^CFLAGS = /CFLAGS = ${CFLAGS} /g" Makefile || \
+ die "sed Makefile failed"
+
+ sed -i -e "s:gcc:$(tc-getCC):g" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin fwlogwatch
+ dosbin contrib/fwlw_notify
+ dosbin contrib/fwlw_respond
+ dodir /usr/share/fwlogwatch/contrib
+ insinto /usr/share/fwlogwatch/contrib
+
+ doins contrib/fwlogsummary.cgi
+ doins contrib/fwlogsummary_small.cgi
+ doins contrib/fwlogwatch.php
+ doins contrib
+ insinto /etc
+
+ doins fwlogwatch.config fwlogwatch.template
+
+ dodoc AUTHORS ChangeLog CREDITS README
+ doman fwlogwatch.8
+}