summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-24 14:11:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-24 14:11:09 +0000
commit889ccaceaf451e5d169ad0ca8ea81fbd9b1a14f5 (patch)
tree1eacbb685ee04eacbd1ae62aa47206a217491113 /net-analyzer/metasploit/metasploit-2.4-r1.ebuild
parentStable on sparc (diff)
downloadhistorical-889ccaceaf451e5d169ad0ca8ea81fbd9b1a14f5.tar.gz
historical-889ccaceaf451e5d169ad0ca8ea81fbd9b1a14f5.tar.bz2
historical-889ccaceaf451e5d169ad0ca8ea81fbd9b1a14f5.zip
FreeBSD fixes: cp -a -> cp -pPR; root:root -> root:0.
Package-Manager: portage-2.0.51.22
Diffstat (limited to 'net-analyzer/metasploit/metasploit-2.4-r1.ebuild')
-rw-r--r--net-analyzer/metasploit/metasploit-2.4-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-analyzer/metasploit/metasploit-2.4-r1.ebuild b/net-analyzer/metasploit/metasploit-2.4-r1.ebuild
index 46f089b13236..2fdef87c5289 100644
--- a/net-analyzer/metasploit/metasploit-2.4-r1.ebuild
+++ b/net-analyzer/metasploit/metasploit-2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-2.4-r1.ebuild,v 1.3 2005/08/12 00:11:44 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-2.4-r1.ebuild,v 1.4 2005/08/24 14:11:09 flameeyes Exp $
MY_P="${P/metasploit/framework}"
S="${WORKDIR}/${MY_P}"
@@ -23,12 +23,12 @@ src_install() {
dodir /usr/bin/
# should be as simple as copying everything into the target...
- cp -a ${S} ${D}usr/lib/metasploit || die
+ cp -pPR ${S} ${D}usr/lib/metasploit || die
# and creating symlinks in the /usr/bin dir
cd ${D}/usr/bin
ln -s ../lib/metasploit/msf* ./ || die
- chown -R root:root ${D}
+ chown -R root:0 ${D}
newinitd ${FILESDIR}/msfweb.initd msfweb || die "newinitd failed"
newconfd ${FILESDIR}/msfweb.confd msfweb || die "newconfd failed"