summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-01-27 11:47:40 +0000
committerMichael Boman <mboman@gentoo.org>2004-01-27 11:47:40 +0000
commit73a5157c0e66aced0686a8504f54ce680d96c4c9 (patch)
tree58106af8cf5f1c4d128a5e5ebd327b1969305244 /net-analyzer/nagios-core
parentMore or less re-wrote the ebuild. Introducing new USE flag: "noweb". Closes b... (diff)
downloadhistorical-73a5157c0e66aced0686a8504f54ce680d96c4c9.tar.gz
historical-73a5157c0e66aced0686a8504f54ce680d96c4c9.tar.bz2
historical-73a5157c0e66aced0686a8504f54ce680d96c4c9.zip
More or less re-wrote the ebuild. Introducing new USE flag: "noweb". Closes bug #20617 and #23669. Removed "gd" flag usage.
Diffstat (limited to 'net-analyzer/nagios-core')
-rw-r--r--net-analyzer/nagios-core/Manifest4
-rw-r--r--net-analyzer/nagios-core/files/digest-nagios-core-1.1-r51
-rw-r--r--net-analyzer/nagios-core/metadata.xml11
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild217
4 files changed, 231 insertions, 2 deletions
diff --git a/net-analyzer/nagios-core/Manifest b/net-analyzer/nagios-core/Manifest
index e108d05173c6..1e19de2b8495 100644
--- a/net-analyzer/nagios-core/Manifest
+++ b/net-analyzer/nagios-core/Manifest
@@ -1,5 +1,5 @@
-MD5 96cbe07485bf91776ef8d6f7911b12de ChangeLog 2399
-MD5 9523fc24cea71b0f2b130ceba153e48c nagios-core-1.1-r5.ebuild 5446
+MD5 d133419edacb352f7e08ef274cbe1123 ChangeLog 2874
+MD5 3ded4ec4e85d53a021c13ac3c1733e1a nagios-core-1.1-r5.ebuild 5900
MD5 1253323746ae48a8fcda1bb4d4d75c44 nagios-core-1.1-r4.ebuild 5363
MD5 b480a3a5ddac940e863a185f069a0cc0 metadata.xml 981
MD5 673bda0ac6ab9230d23331e7f3846b7b files/99_nagios.conf 350
diff --git a/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r5 b/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r5
new file mode 100644
index 000000000000..14267bedc75b
--- /dev/null
+++ b/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r5
@@ -0,0 +1 @@
+MD5 5f48ecd9bad2c4d7c9d88d0b6f347ecf nagios-1.1.tar.gz 1619888
diff --git a/net-analyzer/nagios-core/metadata.xml b/net-analyzer/nagios-core/metadata.xml
new file mode 100644
index 000000000000..fe1bb30c5923
--- /dev/null
+++ b/net-analyzer/nagios-core/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>mboman@gentoo.org</email>
+ <name>Michael Boman</name>
+ <description>Interim Maintainer</description>
+</maintainer>
+<longdescription>Nagios is a host and service monitor designed to inform you of network problems before your clients, end-users or managers do. It has been designed to run under the Linux operating system, but works fine under most *NIX variants as well. The monitoring daemon runs intermittent checks on hosts and services you specify using external "plugins" which return status information to Nagios. When problems are encountered, the daemon can send notifications out to administrative contacts in a variety of different ways (email, instant message, SMS, etc.). Current status information, historical logs, and reports can all be accessed via a web browser.</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
new file mode 100644
index 000000000000..b5e603c8e8cc
--- /dev/null
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
@@ -0,0 +1,217 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.1 2004/01/27 11:47:17 mboman Exp $
+
+inherit eutils
+
+DESCRIPTION="Nagios ${PV} core - Host and service monitor cgi, docs etc..."
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagios/nagios-1.1.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="noweb mysql postgres perl debug apache2"
+
+DEPEND=">=net-mail/mailx-8.1
+ !noweb? (
+ >=media-libs/jpeg-6b-r3
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/libgd-1.8.3-r5
+
+ apache2? ( >=net-www/apache-2.0.43-r1 )
+ !apache2? ( <net-www/apache-2 )
+ )
+
+ perl? ( >=dev-lang/perl-5.6.1-r7 )
+ mysql? ( >=dev-db/mysql-3.23.56 )
+ pgsql? ( >=dev-db/postgresql-7.3.2 )"
+
+
+S="${WORKDIR}/nagios-${PV}"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /dev/null nagios
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/Makefile-distclean.diff.bz2
+ use noweb || epatch ${FILESDIR}/tac.cgi.diff.bz2
+}
+
+src_compile() {
+ if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
+ eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
+
+ has_version ">=sys-apps/portage-2.0.50" && (
+ einfo "You can add:"
+ einfo "net-analyzer/nagios-core [use flags]"
+ einfo "to the file:"
+ einfo "/etc/portage/package.use"
+ einfo "to permamently set this package's USE flags"
+ )
+
+ exit 1
+ fi
+
+ local myconf
+
+ use mysql && myconf="${myconf} \
+ --with-mysql-xdata \
+ --with-mysql-status \
+ --with-mysql-comments \
+ --with-mysql-extinfo \
+ --with-mysql-retention \
+ --with-mysql-downtime"
+
+ use postgres && myconf="${myconf} \
+ --with-pgsql-xdata \
+ --with-pgsql-status \
+ --with-pgsql-comments \
+ --with-pgsql-extinfo \
+ --with-pgsql-retention \
+ --with-pgsql-downtime"
+
+ use perl && myconf="${myconf} \
+ --enable-embedded-perl \
+ --with-perlcache"
+
+ if [ -n "`use debug`" ]; then
+ myconf="${myconf} --enable-DEBUG0"
+ myconf="${myconf} --enable-DEBUG1"
+ myconf="${myconf} --enable-DEBUG2"
+ myconf="${myconf} --enable-DEBUG3"
+ myconf="${myconf} --enable-DEBUG4"
+ myconf="${myconf} --enable-DEBUG5"
+ fi
+
+ ./configure ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ make DESTDIR=${D} nagios contrib
+
+ use noweb || make DESTDIR=${D} cgis # Only compile the CGI's if "noweb" useflag is not set.
+}
+
+src_install() {
+ dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
+
+ use noweb || (
+ make DESTDIR=${D} install-html
+ )
+
+ make DESTDIR=${D} install
+ make DESTDIR=${D} install-config
+ make DESTDIR=${D} install-commandmode
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/nagios
+
+ insinto /etc/nagios
+ doins ${FILESDIR}/nagios.cfg-sample
+
+ insinto /usr/nagios/contrib
+ doins contrib/*
+
+ insinto /usr/nagios/contrib/database
+ doins contrib/database/*
+
+ insinto /usr/nagios/contrib/eventhandlers
+ doins contrib/eventhandlers/*
+
+ insinto /usr/nagios/contrib/eventhandlers/distributed-monitoring
+ doins contrib/eventhandlers/distributed-monitoring/*
+
+ insinto /usr/nagios/contrib/eventhandlers/redundancy-scenario1
+ doins contrib/eventhandlers/redundancy-scenario1/*
+}
+
+pkg_preinst() {
+ einfo "Sample config files installed by default will always"
+ einfo "include cgi.cfg"
+ chown -R nagios:nagios ${D}/etc/nagios || die "Failed Chown of ${D}/etc/nagios"
+ keepdir /usr/nagios/share/ssi
+ chown -R nagios:nagios ${D}/usr/nagios || die "Failed Chown of ${D}/usr/nagios"
+ keepdir /var/nagios
+ keepdir /var/nagios/archives
+ chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
+ keepdir /var/nagios/rw
+ chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Remember to edit the config files in /etc/nagios"
+ einfo "Also, if you want nagios to start at boot time"
+ einfo "remember to execute rc-update add nagios default"
+ einfo
+
+ if [ -z "`use noweb`"]; then
+ einfo "This does not include cgis that are perl-dependent"
+ einfo "Currently traceroute.cgi is perl-dependent"
+ einfo "To have ministatus.cgi requires copying of ministatus.c"
+ einfo "to cgi directory for compiling."
+
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
+
+ if [ -z "`use apache2`" ]; then
+ einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
+ else
+ einfo " 2. Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
+ fi
+
+ einfo
+ einfo "That will make nagios's web front end visable via"
+ einfo "http://localhost/nagios/"
+ einfo
+ else
+ einfo "Please note that you have installed Nagios without web interface."
+ einfo "Please don't file any bugs about having no web interface when you do this."
+ einfo "Thank you!"
+ fi
+
+ einfo "If your kernel has /proc protection, nagios"
+ einfo "will not be happy as it relies on accessing the proc"
+ einfo "filesystem. You can fix this by adding nagios into"
+ einfo "the group wheel, but this is not recomended."
+ einfo
+}
+
+pkg_config() {
+ if [ -z "`use noweb`" ]; then
+ if [ -n "`use apache2`" ]; then
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/99_nagios.conf
+
+ einfo
+ einfo "Remember to edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
+ einfo
+ else
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/nagios.conf
+ echo "Include conf/addon-modules/nagios.conf" >> ${ROOT}/etc/apache/conf/apache.conf
+
+ einfo
+ einfo "Remember to edit /etc/conf.d/apache and add \"-D NAGIOS\""
+ einfo
+ fi
+ else
+ einfo "Nothing to configure"
+ fi
+}
+
+pkg_prerm() {
+ /etc/init.d/nagios stop
+}