summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-09 18:17:04 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-09 18:17:04 +0000
commit9bceb0123aed8188c3893a53243d10dc37c7d956 (patch)
tree49e4dcc3049c81934de84e620ffbf13dcbb18058 /net-analyzer/nagios-core
parentFix use invocation and don't run epatch in a subshell because then it can't die (diff)
downloadhistorical-9bceb0123aed8188c3893a53243d10dc37c7d956.tar.gz
historical-9bceb0123aed8188c3893a53243d10dc37c7d956.tar.bz2
historical-9bceb0123aed8188c3893a53243d10dc37c7d956.zip
Fix use invocation
Diffstat (limited to 'net-analyzer/nagios-core')
-rw-r--r--net-analyzer/nagios-core/ChangeLog7
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild18
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild14
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild10
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild10
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.2.ebuild10
6 files changed, 37 insertions, 32 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index fb13cbf6c009..24245a13cf35 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.25 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.26 2004/06/09 18:11:06 agriffis Exp $
+
+ 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> nagios-core-1.1-r4.ebuild,
+ nagios-core-1.1-r5.ebuild, nagios-core-1.1-r6.ebuild,
+ nagios-core-1.2-r1.ebuild, nagios-core-1.2.ebuild:
+ Fix use invocation
30 May 2004; Robin H. Johnson <robbat2@gentoo.org>
nagios-core-1.1-r4.ebuild, nagios-core-1.1-r5.ebuild,
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
index 92938d38c8a1..cb48dd222d58 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.12 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.13 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -37,7 +37,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/Makefile-distclean.diff.bz2
- [ `use gd` ] && epatch ${FILESDIR}/tac.cgi.diff.bz2
+ use gd && epatch ${FILESDIR}/tac.cgi.diff.bz2
}
src_compile() {
@@ -53,7 +53,7 @@ src_compile() {
use perl && myconf="${myconf} --enable-embedded-perl --with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -75,9 +75,9 @@ src_compile() {
src_install() {
dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
- if [ -n "`use gd`" ]; then
+ if use gd; then
make DESTDIR=${D} fullinstall install-config || die
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
else
@@ -122,12 +122,12 @@ pkg_postinst() {
einfo "Also, if you want nagios to start at boot time"
einfo "remember to execute rc-update add nagios default"
einfo
- if [ -n "`use gd`" ]; then
+ if use gd; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
einfo "to cgi directory for compiling"
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
einfo "To have nagios visable on the web, please do the following:"
einfo "Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
einfo "The Apache2 config file for nagios will be in"
@@ -154,8 +154,8 @@ pkg_postinst() {
}
pkg_config() {
- if [ "`use gd`" ]; then
- if [ "`use apache2`" ]; then
+ if use gd; then
+ if use apache2; then
einfo "Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
fi
echo "Include conf/addon-modules/nagios.conf" >> ${ROOT}/etc/apache/conf/apache.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
index 53912dd9cb79..68e44f0668f3 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.5 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.6 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -45,7 +45,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -82,7 +82,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -158,7 +158,7 @@ pkg_postinst() {
einfo "remember to execute rc-update add nagios default"
einfo
- if [ -z "`use noweb`"]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
@@ -167,7 +167,7 @@ pkg_postinst() {
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- if [ -z "`use apache2`" ]; then
+ if ! use apache2; then
einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
else
einfo " 2. Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
@@ -191,8 +191,8 @@ pkg_postinst() {
}
pkg_config() {
- if [ -z "`use noweb`" ]; then
- if [ -n "`use apache2`" ]; then
+ if ! use noweb; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
index 117003a61e00..77a9ef116aee 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild,v 1.6 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild,v 1.7 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -44,7 +44,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -81,7 +81,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -163,7 +163,7 @@ pkg_postinst() {
einfo " rc-update add nagios default"
einfo
- if [ -z "`use noweb`" ]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
@@ -172,7 +172,7 @@ pkg_postinst() {
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild b/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
index aa0f0c7f2e4d..7ed80179fd09 100644
--- a/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild,v 1.2 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild,v 1.3 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -43,7 +43,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -80,7 +80,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -162,13 +162,13 @@ pkg_postinst() {
einfo " rc-update add nagios default"
einfo
- if [ -z "`use noweb`" ]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
einfo "to cgi directory for compiling."
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf
diff --git a/net-analyzer/nagios-core/nagios-core-1.2.ebuild b/net-analyzer/nagios-core/nagios-core-1.2.ebuild
index 163c27b474bd..ce3d3796c4ee 100644
--- a/net-analyzer/nagios-core/nagios-core-1.2.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2.ebuild,v 1.4 2004/05/30 07:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2.ebuild,v 1.5 2004/06/09 18:11:06 agriffis Exp $
inherit eutils
@@ -43,7 +43,7 @@ src_unpack() {
}
src_compile() {
- if [ -n "`use mysql`" -a -n "`use postgres`" ]; then
+ if use mysql && use postgres; then
eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
@@ -80,7 +80,7 @@ src_compile() {
--enable-embedded-perl \
--with-perlcache"
- if [ -n "`use debug`" ]; then
+ if use debug; then
myconf="${myconf} --enable-DEBUG0"
myconf="${myconf} --enable-DEBUG1"
myconf="${myconf} --enable-DEBUG2"
@@ -162,7 +162,7 @@ pkg_postinst() {
einfo " rc-update add nagios default"
einfo
- if [ -z "`use noweb`" ]; then
+ if ! use noweb; then
einfo "This does not include cgis that are perl-dependent"
einfo "Currently traceroute.cgi is perl-dependent"
einfo "To have ministatus.cgi requires copying of ministatus.c"
@@ -171,7 +171,7 @@ pkg_postinst() {
einfo "1. Execute the command:"
einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
- if [ -n "`use apache2`" ]; then
+ if use apache2; then
insinto /etc/apache2/conf/modules.d
doins ${FILESDIR}/99_nagios.conf