summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-26 18:28:16 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-26 18:28:16 +0000
commitd7482a9298cc0131724e16ce08efe123bb9405ed (patch)
treedacf0d788430dc0781a7e1c40e9b8db942c491ae /net-analyzer/nagios-plugins
parentVersion bumped (diff)
downloadhistorical-d7482a9298cc0131724e16ce08efe123bb9405ed.tar.gz
historical-d7482a9298cc0131724e16ce08efe123bb9405ed.tar.bz2
historical-d7482a9298cc0131724e16ce08efe123bb9405ed.zip
Version bumped
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/Manifest4
-rw-r--r--net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.11
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild58
3 files changed, 61 insertions, 2 deletions
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index a9e0e849b662..c2c1f29a422e 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -2,10 +2,10 @@ MD5 99c145046a6a69b0e31e92439843daf6 nagios-plugins-1.3.0.ebuild 1591
MD5 c57d43fc7fb6dabc7e312d4a7b42dfd5 nagios-plugins-1.3.0_beta2.ebuild 1585
MD5 8a4a27af84de93a48f25bbb0a7cf8765 nagios-plugins-1.3.0-r1.ebuild 1612
MD5 877654bf22f7a20e72e13a5863b42f4a nagios-plugins-1.3.0_beta3.ebuild 1609
-MD5 db1be96c6f8646c8acd07b3c2dd74227 nagios-plugins-1.3.1.ebuild 1773
+MD5 7b6a7eb4c9b7d9507b82a42839f95eee nagios-plugins-1.3.1.ebuild 1772
MD5 db1be96c6f8646c8acd07b3c2dd74227 nagios-plugins-1.3.0-r2.ebuild 1773
MD5 63b53c4718dffffb678b2551845b35da nagios-plugins-1.3.0_beta3-r1.ebuild 1641
-MD5 07d471f3c74cff8e3cc44fa8fba25c69 ChangeLog 2536
+MD5 b3d233229e1334d3f2296111fd3ccedd ChangeLog 2671
MD5 f180834b2d2a6e5e853eb436dd19d9d5 nagios-plugins-1.3.0_beta2-r1.ebuild 1670
MD5 39af7074b023625d9a75730bd6932437 files/digest-nagios-plugins-1.3.1 72
MD5 2964d08030df634e1ea894eb1a6eea0b files/digest-nagios-plugins-1.3.0-r2 72
diff --git a/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1 b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1
new file mode 100644
index 000000000000..52ae36d236e9
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1
@@ -0,0 +1 @@
+MD5 0078c9c8137694181a4cdf596fdbd74f nagios-plugins-1.3.1.tar.gz 532516
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild
new file mode 100644
index 000000000000..ed3c5d553041
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1.ebuild,v 1.1 2003/11/26 18:28:11 mholzer Exp $
+
+inherit eutils
+
+DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagiosplug/${P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="ssl samba mysql postgres ldap"
+#RDEPEND=">=net-analyzer/nagios-core-1.0"
+DEPEND=">=net-dns/bind-tools-9.2.2_rc1
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ >=dev-lang/perl-5.6.1-r7
+ >=net-analyzer/fping-2.4_beta2-r1
+ >=net-misc/ntp-4.1.1a
+ >=dev-perl/Net-SNMP-4.0.1-r1
+ >=net-analyzer/net-snmp-5.0.6
+ samba? ( >=net-fs/samba-2.2.5-r1 )
+ >=net-misc/openssh-3.5_p1
+ mysql? ( >=dev-db/mysql-3.23.52-r1 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ ldap? ( >=net-nds/openldap-2.0.25 )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /dev/null nagios
+}
+
+src_compile() {
+ local myconf
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+ use openssl && myconf="${myconf} --with-openssl"
+
+ ./configure ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --with-nagios-user=nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
+ make DESTDIR=${D} install || die
+}
+pkg_preinst() {
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
+}