summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-01-09 10:56:50 +0000
committerPeter Volkov <pva@gentoo.org>2006-01-09 10:56:50 +0000
commit47f899877fe82af148cf4ed21e9527e448640703 (patch)
tree4f700becdbab95dc63d809af8ad20bb23ecfc5d0 /net-analyzer/ndsad/ndsad-1.33.ebuild
parenthttp://kernel.org/pub -> mirror://kernel/ in SRC_URI (diff)
downloadhistorical-47f899877fe82af148cf4ed21e9527e448640703.tar.gz
historical-47f899877fe82af148cf4ed21e9527e448640703.tar.bz2
historical-47f899877fe82af148cf4ed21e9527e448640703.zip
Initial bump.
Package-Manager: portage-2.0.53
Diffstat (limited to 'net-analyzer/ndsad/ndsad-1.33.ebuild')
-rw-r--r--net-analyzer/ndsad/ndsad-1.33.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-analyzer/ndsad/ndsad-1.33.ebuild b/net-analyzer/ndsad/ndsad-1.33.ebuild
new file mode 100644
index 000000000000..c9a7428f9a3f
--- /dev/null
+++ b/net-analyzer/ndsad/ndsad-1.33.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndsad/ndsad-1.33.ebuild,v 1.1 2006/01/09 10:56:49 pva Exp $
+
+DESCRIPTION="NetUP Data Stream Accounting Daemon"
+HOMEPAGE="http://sourceforge.net/projects/ndsad"
+SRC_URI="mirror://sourceforge/ndsad/ndsad-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/libpcap-0.8"
+DEPEND="${RDEPEND}
+ =sys-devel/automake-1.7*
+ =sys-devel/autoconf-2.5*"
+
+src_unpack() {
+ einfo "Regenerating autotools files..."
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+
+ unpack ${A}
+
+ cd ${S}
+
+ # Puttind ndsad binary in sbin.
+ sed -i "s/bin_PROGRAMS = ndsad/sbin_PROGRAMS = ndsad/" Makefile.am || \
+ die "Can not change bin->sbin in Makefile.am... sed failed"
+
+ sed -i \
+ "s:^#define conf_path \"/netup/utm5/ndsad.cfg\":#define conf_path \"/etc/ndsad.conf\":" \
+ ndsad.cc || die "Can not change default config path... sed failed"
+
+ sed -i "s:log /tmp/ndsad.log:log /var/log/ndsad.log:" ndsad.conf || \
+ die "Can not fix logging path in ndsad.conf... sed failed"
+
+ ./preconf
+}
+
+src_compile() {
+ econf --with-ulog=yes || die "configure failed"
+ emake || die "compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ doman ndsad.conf.5
+
+ insinto /etc
+ newins ndsad.conf ndsad.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ndsad.init ndsad
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/ndsad.conf.d ndsad
+
+ dodoc ChangeLog AUTHORS README
+}