summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-23 09:53:41 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-23 09:53:41 +0000
commit3bcdc56e9a95f33d43949686e83700389380a935 (patch)
treec3d8ca4fcd2735ed648cfdf563259a926fd240ba /net-analyzer/nessus-core
parentx86 stable (diff)
downloadhistorical-3bcdc56e9a95f33d43949686e83700389380a935.tar.gz
historical-3bcdc56e9a95f33d43949686e83700389380a935.tar.bz2
historical-3bcdc56e9a95f33d43949686e83700389380a935.zip
Version bump - Security update (x86 stable). Bug 58014.
Diffstat (limited to 'net-analyzer/nessus-core')
-rw-r--r--net-analyzer/nessus-core/ChangeLog7
-rw-r--r--net-analyzer/nessus-core/files/digest-nessus-core-2.0.122
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.12.ebuild70
3 files changed, 78 insertions, 1 deletions
diff --git a/net-analyzer/nessus-core/ChangeLog b/net-analyzer/nessus-core/ChangeLog
index a69a4f12960e..f60c85ddb356 100644
--- a/net-analyzer/nessus-core/ChangeLog
+++ b/net-analyzer/nessus-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nessus-core
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.37 2004/07/21 07:00:37 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.38 2004/07/23 09:53:41 eldad Exp $
+
+*nessus-core-2.0.12 (23 Jul 2004)
+
+ 23 Jul 2004; Eldad Zack <eldad@gentoo.org> +nessus-core-2.0.12.ebuild:
+ Version bump - Security update (x86 stable). Bug 58014.
*nessus-core-2.0.11 (21 Jul 2004)
diff --git a/net-analyzer/nessus-core/files/digest-nessus-core-2.0.12 b/net-analyzer/nessus-core/files/digest-nessus-core-2.0.12
new file mode 100644
index 000000000000..0c1f4c6b4a55
--- /dev/null
+++ b/net-analyzer/nessus-core/files/digest-nessus-core-2.0.12
@@ -0,0 +1,2 @@
+MD5 23017718a25848d3629e57ea2b72a421 nessus-core-2.0.12.tar.gz 649412
+MD5 67cebc91a36613efe6524cea3631290e patch_0.nessus-core.2.0.7 54443
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.12.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.12.ebuild
new file mode 100644
index 000000000000..e6c2df2d0cf0
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-2.0.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.12.ebuild,v 1.1 2004/07/23 09:53:41 eldad Exp $
+
+inherit eutils
+
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz
+ prelude? ( http://www.exaprobe.com/labs/downloads/Nessus_Patch/patch_0.nessus-core.2.0.7 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="X tcpd gtk2 debug prelude"
+
+DEPEND="=net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
+ X? ( virtual/x11
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ )
+ prelude? ( dev-libs/libprelude )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ if use prelude; then
+ epatch ${DISTDIR}/patch_0.nessus-core.2.0.7
+ epatch ${FILESDIR}/patch_1.nessus-core.2.0.7
+ fi
+}
+
+src_compile() {
+ local myconf
+ # no use_enable because of bug 31670
+ if use tcpd; then
+ myconf="${myconf} --enable-tcpwrappers"
+ fi
+ if use debug; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+ if use prelude; then
+ export LIBPRELUDE_CONFIG=/usr/bin/libprelude-config
+ fi
+ use X || myconf="${myconf} --disable-gtk"
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man \
+ install || die "Install failed nessus-core"
+ cd ${S}
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+ insinto /etc/init.d
+ insopts -m 755
+ newins ${FILESDIR}/nessusd-r6 nessusd
+ keepdir /var/lib/nessus/logs
+ keepdir /var/lib/nessus/users
+}