summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-16 07:55:42 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-16 07:55:42 +0000
commit8b02f4b42b677286a823e6eb05da880c8149b5f7 (patch)
tree1cd003a82d927c1ef9f5e440b5ce929b47cb9c80 /net-analyzer/nmap/nmap-6.25.ebuild
parentwhitespace (diff)
downloadhistorical-8b02f4b42b677286a823e6eb05da880c8149b5f7.tar.gz
historical-8b02f4b42b677286a823e6eb05da880c8149b5f7.tar.bz2
historical-8b02f4b42b677286a823e6eb05da880c8149b5f7.zip
Respect AR and RANLIB, wrt bug #445524. Thanks to Agostino Sarubbo for discovering this issue
Package-Manager: portage-2.2.0_alpha153/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/nmap/nmap-6.25.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-6.25.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-analyzer/nmap/nmap-6.25.ebuild b/net-analyzer/nmap/nmap-6.25.ebuild
index effca50ced65..0f7af9b156df 100644
--- a/net-analyzer/nmap/nmap-6.25.ebuild
+++ b/net-analyzer/nmap/nmap-6.25.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.25.ebuild,v 1.6 2013/01/15 17:03:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.25.ebuild,v 1.7 2013/01/16 07:55:37 pinkbyte Exp $
EAPI="4"
PYTHON_DEPEND="2"
-inherit eutils flag-o-matic python
+inherit eutils flag-o-matic python toolchain-funcs
MY_P=${P/_beta/BETA}
@@ -103,6 +103,12 @@ src_prepare() {
-e 's|^Categories=.*|Categories=Network;System;Security;|g' \
zenmap/install_scripts/unix/zenmap-root.desktop \
zenmap/install_scripts/unix/zenmap.desktop || die
+
+ # respect AR and RANLIB, wrt bug #445524
+ tc-export AR RANLIB
+ sed -i -e '/^RANLIB/d' -e '/^AR/d' liblinear/{,blas}/Makefile || die
+ sed -i -e '/^RANLIB/d' -e '/^AR/d' liblua/Makefile || die
+ sed -i -e '/^AR/d' {libnetutil,libpcre,nbase,nsock/src}/Makefile.in || die
}
src_configure() {