summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-05 15:16:37 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-05 15:16:37 +0000
commit13b0a09201f90dac80f4e6871e498f05c0ee2d48 (patch)
tree6787185d028a2eaff491910d3619212c11232762 /net-analyzer/ntop/ntop-2.2c.ebuild
parentpre6 was a buggy version. version bumped to pre7 and fixed savedconfig. (diff)
downloadhistorical-13b0a09201f90dac80f4e6871e498f05c0ee2d48.tar.gz
historical-13b0a09201f90dac80f4e6871e498f05c0ee2d48.tar.bz2
historical-13b0a09201f90dac80f4e6871e498f05c0ee2d48.zip
AMD64 Keyword and other fixes
Diffstat (limited to 'net-analyzer/ntop/ntop-2.2c.ebuild')
-rw-r--r--net-analyzer/ntop/ntop-2.2c.ebuild37
1 files changed, 31 insertions, 6 deletions
diff --git a/net-analyzer/ntop/ntop-2.2c.ebuild b/net-analyzer/ntop/ntop-2.2c.ebuild
index 3555665717ae..350812fd1c6d 100644
--- a/net-analyzer/ntop/ntop-2.2c.ebuild
+++ b/net-analyzer/ntop/ntop-2.2c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2c.ebuild,v 1.4 2004/01/12 02:37:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2c.ebuild,v 1.5 2004/02/05 15:16:37 aliz Exp $
IUSE="ssl readline tcpd ncurses"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.ntop.org/ntop.html"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc hppa"
+KEYWORDS="x86 ~ppc ~sparc hppa ~amd64"
DEPEND=">=sys-libs/gdbm-1.8.0
>=net-libs/libpcap-0.5.2
@@ -20,6 +20,28 @@ DEPEND=">=sys-libs/gdbm-1.8.0
readline? ( >=sys-libs/readline-4.1 )
ncurses? ( sys-libs/ncurses )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/../gdchart0.94c/zlib-1.1.4/
+ epatch ${FILESDIR}/zlib-1.1.4-gzprintf.patch
+ epatch ${FILESDIR}/zlib-1.1.4-glibc.patch
+ epatch ${FILESDIR}/zlib-1.1.4-build-fPIC.patch
+ epatch ${FILESDIR}/zlib-1.1.4-mapfile.patch
+ epatch ${FILESDIR}/zlib-1.1.4-build-static-with-fpic.patch
+
+ cd ${S}/../gdchart0.94c/
+ epatch ${FILESDIR}/gdchart0.94c-fpic.patch
+
+ cd ${S}/../gdchart0.94c/gd-1.8.3/
+ epatch ${FILESDIR}/gd-1.8.3-fpic.patch
+
+ cd ${S}/../gdchart0.94c/gd-1.8.3/libpng-1.2.4/
+ epatch ${FILESDIR}/libpng-1.2.4-fpic.patch
+
+}
+
src_compile() {
cd ${S}
@@ -35,25 +57,28 @@ src_compile() {
# shipped with just in case future versions are incompatible -- blocke
# compile gdchart
+ einfo "Configure gdchart"
cd ../gdchart0.94c
./configure || die "gdchart configure problem"
# subtree #1
+ einfo "Compiling libpng"
cd gd-1.8.3/libpng-1.2.4
- [ "${ARCH}" = "hppa" ] && sed -i scripts/makefile.linux -e "/^CFLAGS/s/-O3/-O3 -fPIC/"
- make -f scripts/makefile.linux || die "libpng compile problem"
+ make -f scripts/makefile.linux CFLAGS="${CFLAGS}" || die "libpng compile problem"
# subtree #2
+ einfo "Compiling zlib"
cd ../../zlib-1.1.4/
./configure || die "zlib configure problem"
- [ "${ARCH}" = "hppa" ] && sed -i Makefile -e "/^CFLAGS/s/$/ -fPIC/"
make || die "zlib compile problem"
# gdchart make
+ einfo "Compiling gdchart"
cd ../
- make || die "gdchart compile problem"
+ make CFLAGS="${CFLAGS}" || die "gdchart compile problem"
# now ntop itself...
+ einfo "Compiling ntop"
cd ../ntop
econf ${myconf} || die "configure problem"
make || die "compile problem"