summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-06-01 22:26:33 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-06-01 22:26:33 +0000
commit02762ce47f6323a36d082c8f66cd708726c5699f (patch)
tree505526c3f79628019a47cd1ad8b314df1bace135 /net-analyzer/rtg
parentChange xpdfrc paths, thanks to Ulf <fly-a-lot@web.de> in bug 134537, and add ... (diff)
downloadhistorical-02762ce47f6323a36d082c8f66cd708726c5699f.tar.gz
historical-02762ce47f6323a36d082c8f66cd708726c5699f.tar.bz2
historical-02762ce47f6323a36d082c8f66cd708726c5699f.zip
Fixing init.d wrt bug #130298 and cleaning up
Package-Manager: portage-2.1_rc1-r3
Diffstat (limited to 'net-analyzer/rtg')
-rw-r--r--net-analyzer/rtg/ChangeLog8
-rw-r--r--net-analyzer/rtg/files/digest-rtg-0.7.4-r23
-rw-r--r--net-analyzer/rtg/files/rtgpoll.initd4
-rw-r--r--net-analyzer/rtg/rtg-0.7.4-r2.ebuild51
4 files changed, 63 insertions, 3 deletions
diff --git a/net-analyzer/rtg/ChangeLog b/net-analyzer/rtg/ChangeLog
index 7074af39b5a3..4682e2cc65db 100644
--- a/net-analyzer/rtg/ChangeLog
+++ b/net-analyzer/rtg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/rtg
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtg/ChangeLog,v 1.7 2006/01/08 00:54:58 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtg/ChangeLog,v 1.8 2006/06/01 22:26:33 jokey Exp $
+
+*rtg-0.7.4-r2 (01 Jun 2006)
+
+ 01 Jun 2006; Markus Ullmann <jokey@gentoo.org> files/rtgpoll.initd,
+ -rtg-0.7.4.ebuild, -rtg-0.7.4-r1.ebuild, +rtg-0.7.4-r2.ebuild:
+ Fixing init.d wrt bug #130298 and cleaning up
08 Jan 2006; Marcelo Goes <vanquirius@gentoo.org> metadata.xml:
Remove anti from metadata (retired), add netmon as a herd.
diff --git a/net-analyzer/rtg/files/digest-rtg-0.7.4-r2 b/net-analyzer/rtg/files/digest-rtg-0.7.4-r2
new file mode 100644
index 000000000000..405c5ef89685
--- /dev/null
+++ b/net-analyzer/rtg/files/digest-rtg-0.7.4-r2
@@ -0,0 +1,3 @@
+MD5 c61ff1323701e2771bb5ff9cf67f1b77 rtg-0.7.4.tar.gz 710621
+RMD160 9839b8c71766dbdd8f230dcfb3688ad4464a16a3 rtg-0.7.4.tar.gz 710621
+SHA256 db0dfefe335d551aaaa3e60876a1431916e7db55c980902413711512dd2132a0 rtg-0.7.4.tar.gz 710621
diff --git a/net-analyzer/rtg/files/rtgpoll.initd b/net-analyzer/rtg/files/rtgpoll.initd
index 48f4bbf0c341..bfb81a606b19 100644
--- a/net-analyzer/rtg/files/rtgpoll.initd
+++ b/net-analyzer/rtg/files/rtgpoll.initd
@@ -1,14 +1,14 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtg/files/rtgpoll.initd,v 1.2 2004/07/14 23:10:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtg/files/rtgpoll.initd,v 1.3 2006/06/01 22:26:33 jokey Exp $
[ -z "${RTGPOLL_TARGETS}" ] && RTGPOLL_TARGETS=/etc/rtg/targets.cfg
opts="${opts} reload"
depend() {
- need net mysql
+ need net
}
checkconfig() {
diff --git a/net-analyzer/rtg/rtg-0.7.4-r2.ebuild b/net-analyzer/rtg/rtg-0.7.4-r2.ebuild
new file mode 100644
index 000000000000..95b726e56b49
--- /dev/null
+++ b/net-analyzer/rtg/rtg-0.7.4-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rtg/rtg-0.7.4-r2.ebuild,v 1.1 2006/06/01 22:26:33 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="RTG: Real Traffic Grabber"
+HOMEPAGE="http://rtg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rtg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-db/mysql-3.23.52-r1
+ >=net-analyzer/net-snmp-5.0.9-r1"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-pathfix.patch
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/rtg \
+ --datadir=/usr/share/rtg \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc FAQ README
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/rtgpoll.confd rtgpoll
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rtgpoll.initd rtgpoll
+}
+
+pkg_postinst() {
+ einfo "RTG has been installed."
+ einfo
+ einfo "The default configuration file location is now /etc/rtg"
+ einfo
+ einfo "Sample reports have been installed into /usr/share/rtg"
+ einfo
+}