summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-24 05:54:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-24 05:54:52 +0000
commiteae5a97ad355d202a877953eadcc20e012ceb08c (patch)
tree1cce2b7f79e46bbd4c25070496b421aa58429586 /net-analyzer/vnstat
parentMoving auto* out of RDEPEND. (diff)
downloadhistorical-eae5a97ad355d202a877953eadcc20e012ceb08c.tar.gz
historical-eae5a97ad355d202a877953eadcc20e012ceb08c.tar.bz2
historical-eae5a97ad355d202a877953eadcc20e012ceb08c.zip
install crontab into /etc/cron.d instead
Diffstat (limited to 'net-analyzer/vnstat')
-rw-r--r--net-analyzer/vnstat/Manifest16
-rw-r--r--net-analyzer/vnstat/files/vnstat.cron6
-rw-r--r--net-analyzer/vnstat/vnstat-1.4.ebuild7
3 files changed, 20 insertions, 9 deletions
diff --git a/net-analyzer/vnstat/Manifest b/net-analyzer/vnstat/Manifest
index a01a7f35c654..07e1933e0bd8 100644
--- a/net-analyzer/vnstat/Manifest
+++ b/net-analyzer/vnstat/Manifest
@@ -1,7 +1,17 @@
-MD5 27294d43fcabb1b03b7b1a90139c5a42 vnstat-1.4.ebuild 1219
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 3a7336b95de3d598af4ad0a1ce9f460f ChangeLog 774
-MD5 432c6dc3dfd22b4c6657ddcc6c37979e metadata.xml 271
MD5 eb0a408331b471c0ce66781c2cf44ada vnstat-1.1.ebuild 645
-MD5 e00cefa01ca437c27e38d078c012403c files/vnstat.cron 148
+MD5 bcb1e9649a3516f335006b8843457a08 vnstat-1.4.ebuild 1329
+MD5 432c6dc3dfd22b4c6657ddcc6c37979e metadata.xml 271
+MD5 c902f7de560cb98f380cf3e6a00ec61f files/vnstat.cron 176
MD5 afdaa51d96e363c56fe7358b1c5814c5 files/digest-vnstat-1.1 61
MD5 94dd735fdba2070fefd9f85480b1a2b9 files/digest-vnstat-1.4 61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFBAfmyHTu7gpaalycRAsq2AKC7JA2A7lEVKL6tnfUMZ8YGM/tCHwCgjyEx
+HftrKDurgDZzfZwNcR1/vRw=
+=NiFN
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/vnstat/files/vnstat.cron b/net-analyzer/vnstat/files/vnstat.cron
index 716405fe50c8..9315bcefc5df 100644
--- a/net-analyzer/vnstat/files/vnstat.cron
+++ b/net-analyzer/vnstat/files/vnstat.cron
@@ -1,8 +1,6 @@
#!/bin/bash
-# uncomment this line to enable this cron script
-exit 0
-
-if [ `ls /var/lib/vnstat/ | wc -l` -ge 1 ] ; then
+# run vnstat if installed and at least one database exists
+if [ -x /usr/bin/vnstat ] && [ `ls /var/lib/vnstat/ | wc -l` -ge 1 ] ; then
exec /usr/bin/vnstat -u
fi
diff --git a/net-analyzer/vnstat/vnstat-1.4.ebuild b/net-analyzer/vnstat/vnstat-1.4.ebuild
index 1213871c2a4b..a0e5e20b2d9b 100644
--- a/net-analyzer/vnstat/vnstat-1.4.ebuild
+++ b/net-analyzer/vnstat/vnstat-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/vnstat-1.4.ebuild,v 1.5 2004/07/10 15:40:48 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/vnstat-1.4.ebuild,v 1.6 2004/07/24 05:54:52 vapier Exp $
DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
HOMEPAGE="http://humdi.net/vnstat/"
@@ -21,7 +21,7 @@ src_install() {
keepdir /var/lib/vnstat
dobin src/vnstat || die
- insinto /etc/cron.hourly
+ insinto /etc/cron.d
newins ${FILESDIR}/vnstat.cron vnstat
doman man/vnstat.1
@@ -41,4 +41,7 @@ pkg_postinst() {
einfo "Repeat the following command for every interface you"
einfo "wish to monitor (replace eth0):"
einfo " vnstat -u -i eth0"
+
+ einfo "Note: if an interface transfers more than ~4GB in"
+ einfo "the time between cron runs, you may miss traffic"
}