summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-01-14 00:00:13 +0000
committerDean Bailey <alron@gentoo.org>2003-01-14 00:00:13 +0000
commit22dd8b8ef327e35e823215bf3414b3dc8fdc6be5 (patch)
tree720d654acd691e06f31a5182a72de79f69faa666 /net-analyzer
parentnew nagios-nsca (diff)
downloadhistorical-22dd8b8ef327e35e823215bf3414b3dc8fdc6be5.tar.gz
historical-22dd8b8ef327e35e823215bf3414b3dc8fdc6be5.tar.bz2
historical-22dd8b8ef327e35e823215bf3414b3dc8fdc6be5.zip
new nagios suite
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios/ChangeLog5
-rw-r--r--net-analyzer/nagios/nagios-1.0.ebuild35
2 files changed, 39 insertions, 1 deletions
diff --git a/net-analyzer/nagios/ChangeLog b/net-analyzer/nagios/ChangeLog
index 5f2069bf3702..c01b6101be77 100644
--- a/net-analyzer/nagios/ChangeLog
+++ b/net-analyzer/nagios/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for net-analyzer/nagios
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.4 2002/11/19 08:53:07 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.5 2003/01/14 00:00:13 alron Exp $
+*nagios-1.0 (13 Jan 2003)
+ 13 Jan 2003; Dean Bailey <alron@gentoo.org> nagios-1.0 :
+ Updated to latest version.
*nagios-1.0_beta6 (19 Nov 2002)
19 Nov 2002; Dean Bailey <alron@gentoo.org> nagios-1.0_beta6 :
Whoops, I guess I didnt fix it properly last time.
diff --git a/net-analyzer/nagios/nagios-1.0.ebuild b/net-analyzer/nagios/nagios-1.0.ebuild
new file mode 100644
index 000000000000..9b3c9f235282
--- /dev/null
+++ b/net-analyzer/nagios/nagios-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-1.0.ebuild,v 1.1 2003/01/14 00:00:13 alron Exp $
+
+DESCRIPTION="Nagios $PV - merge this to pull install all of the nagios packages"
+HOMEPAGE="http://www.nagios.org/"
+RDEPEND=`echo ~net-analyzer/nagios-{core-1.0,plugins-1.3.0_beta2,nrpe-1.7,nsca-2.2,imagepack-1.0}`
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+pkg_postinst() {
+ einfo
+ einfo "Remember to edit the config files in /etc/nagios"
+ einfo "Also, if you want nagios to start at boot time"
+ einfo "remember to execute rc-update add nagios default"
+ einfo
+ einfo "To have nagios visable on the web, please do the following:"
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/net-analyzer/nagios-core-${PV}/nagios-core-${PF}.ebuild config\""
+ einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
+ einfo
+ einfo "That will make nagios's web front end visable via"
+ einfo "http://localhost/nagios/"
+ einfo
+ einfo "The Apache config file for nagios will be in"
+ einfo "/etc/apache/conf/addon-modules/ with the name of"
+ einfo "nagios.conf."
+ einfo "Also, if your kernel has /proc protection, nagios"
+ einfo "will not be happy as it relies on accessing the proc"
+ einfo "filesystem."
+ einfo
+}
+
+