summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2005-01-12 22:00:20 +0000
committerMatthew Marlowe <mattm@gentoo.org>2005-01-12 22:00:20 +0000
commit31f98daeec9254c6fbd511864baae8b20dc46093 (patch)
tree2191e82755a8fb46c643b3e3ad51a1cced7c8c74 /net-analyzer
parentstable on x86 (diff)
downloadhistorical-31f98daeec9254c6fbd511864baae8b20dc46093.tar.gz
historical-31f98daeec9254c6fbd511864baae8b20dc46093.tar.bz2
historical-31f98daeec9254c6fbd511864baae8b20dc46093.zip
initial commit
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/hyperic-hq-agent/ChangeLog7
-rw-r--r--net-analyzer/hyperic-hq-agent/Manifest5
-rw-r--r--net-analyzer/hyperic-hq-agent/files/digest-hyperic-hq-agent-2.0.221
-rwxr-xr-xnet-analyzer/hyperic-hq-agent/files/hyperic-hq-agent.init-2.0.2217
-rw-r--r--net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.0.22.ebuild48
-rw-r--r--net-analyzer/hyperic-hq-agent/metadata.xml10
6 files changed, 88 insertions, 0 deletions
diff --git a/net-analyzer/hyperic-hq-agent/ChangeLog b/net-analyzer/hyperic-hq-agent/ChangeLog
new file mode 100644
index 000000000000..09d537f8869a
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-analyzer/hyperic-hq-agent
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hyperic-hq-agent/ChangeLog,v 1.1 2005/01/12 22:00:19 mattm Exp $
+
+ 12 Jan 2005; Matthew Marlowe <mattm@gentoo.org> :
+ Initial commit of hyperic-hq-agent using latest upstream version.
+
diff --git a/net-analyzer/hyperic-hq-agent/Manifest b/net-analyzer/hyperic-hq-agent/Manifest
new file mode 100644
index 000000000000..1be6812a7884
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/Manifest
@@ -0,0 +1,5 @@
+MD5 2f2a26b02f8af6c2c623ddc2b046b9d5 hyperic-hq-agent-2.0.22.ebuild 1471
+MD5 eddcfeabec90c590787504b96256b98a metadata.xml 475
+MD5 6f0990f1c5521511f584b7014bb59f49 ChangeLog 351
+MD5 88d8935e0b43d887b7f974d1acae0fcb files/hyperic-hq-agent.init-2.0.22 267
+MD5 b46aa04c4986f8d6c67c8eaab3771796 files/digest-hyperic-hq-agent-2.0.22 74
diff --git a/net-analyzer/hyperic-hq-agent/files/digest-hyperic-hq-agent-2.0.22 b/net-analyzer/hyperic-hq-agent/files/digest-hyperic-hq-agent-2.0.22
new file mode 100644
index 000000000000..4bbe25c31cda
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/files/digest-hyperic-hq-agent-2.0.22
@@ -0,0 +1 @@
+MD5 bb20cfbbe70d6fceadde45f41258cd05 hyperic-hq-agent-2.0.22.tgz 37570385
diff --git a/net-analyzer/hyperic-hq-agent/files/hyperic-hq-agent.init-2.0.22 b/net-analyzer/hyperic-hq-agent/files/hyperic-hq-agent.init-2.0.22
new file mode 100755
index 000000000000..20268e4bca8b
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/files/hyperic-hq-agent.init-2.0.22
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net clock hostname
+}
+
+start() {
+ ebegin "Starting Hyperic HQ Agent"
+ /opt/hyperic-hq-agent-2.0.22/hq-agent.sh start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Hyperic HQ Agent"
+ /opt/hyperic-hq-agent-2.0.22/hq-agent.sh stop
+ eend $?
+}
diff --git a/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.0.22.ebuild b/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.0.22.ebuild
new file mode 100644
index 000000000000..60c764dc5dfe
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.0.22.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hyperic-hq-agent/hyperic-hq-agent-2.0.22.ebuild,v 1.1 2005/01/12 22:00:20 mattm Exp $
+
+inherit eutils
+
+DESCRIPTION="Agent for HQ Monitoring Software by Hyperic LLC"
+HOMEPAGE="http://www.hyperic.com/"
+SRC_URI="http://download.hyperic.net/downloads/ebuilds/hyperic-hq-agent-${PV}.tgz"
+
+LICENSE="hyperic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+AGENT_HOME=/opt/hyperic-hq-agent-${PV}
+
+src_install() {
+
+ dodoc README.txt
+
+ insinto /etc/init.d
+ insopts -m0750
+ newins ${FILESDIR}/hyperic-hq-agent.init-${PV} hyperic-hq-agent
+
+ dodir ${AGENT_HOME}
+ cp -a ${S}/* ${D}${AGENT_HOME}
+}
+
+pkg_preinst() {
+ enewgroup hyperic
+ enewuser hyperic -1 -1 /dev/null hyperic
+}
+
+pkg_postinst() {
+ chown -R hyperic:hyperic ${AGENT_HOME}
+
+ einfo "You should perform the following before attempting to start the agent:"
+ einfo ""
+ einfo "1) read and agree to the _commercial license_ at /usr/portage/licenses/hyperic"
+ einfo "2) ensure that your server has a license key permitting an additional agent install."
+ einfo "3) have your server ip, admin username, and admin password available"
+ einfo "4) run /opt/hyperic-hq-agent-${PV}/hq-agent.sh start and answer setup questions"
+ einfo "5) run /opt/hyperic-hq-agent-${PV}/hq-agent.sh stop"
+ einfo "6) rc-update add hyperic-hq-agent default"
+ einfo "7) /etc/init.d/hyperic-hq-agent start"
+ einfo
+}
diff --git a/net-analyzer/hyperic-hq-agent/metadata.xml b/net-analyzer/hyperic-hq-agent/metadata.xml
new file mode 100644
index 000000000000..385fa10508ec
--- /dev/null
+++ b/net-analyzer/hyperic-hq-agent/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mattm@gentoo.org</email>
+ <name>Matthew Marlowe</name>
+ </maintainer>
+ <longdescription>The hyperic-hq-agent allows the hyperic server to monitor an extensive set of system metrics, including the health of mysql, apache, tomcat, and various other enterprise applications.</longdescription>
+</pkgmetadata>