summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-09-27 17:53:16 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-09-27 17:53:16 +0000
commit4b8549f5d91c3dae8b896e7caa70b7e21424bc7b (patch)
tree9bdf19f306599a1e6a9bb4c0eccae08beb7b3515 /net-analyzer
parentForgot to add patch. (diff)
downloadhistorical-4b8549f5d91c3dae8b896e7caa70b7e21424bc7b.tar.gz
historical-4b8549f5d91c3dae8b896e7caa70b7e21424bc7b.tar.bz2
historical-4b8549f5d91c3dae8b896e7caa70b7e21424bc7b.zip
Fixed broken sed line.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/portsentry/ChangeLog8
-rw-r--r--net-analyzer/portsentry/files/digest-portsentry-1.1-r71
-rw-r--r--net-analyzer/portsentry/portsentry-1.1-r7.ebuild52
3 files changed, 60 insertions, 1 deletions
diff --git a/net-analyzer/portsentry/ChangeLog b/net-analyzer/portsentry/ChangeLog
index 050c1f62f9d9..4c25b4d5b417 100644
--- a/net-analyzer/portsentry/ChangeLog
+++ b/net-analyzer/portsentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/portsentry
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/ChangeLog,v 1.4 2002/08/10 00:00:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/ChangeLog,v 1.5 2002/09/27 17:53:16 g2boojum Exp $
+
+*portsentry-1.1-r7 (27 Sept. 2002)
+
+ 27 Sept. 2002; Grant Goodyear <g2boojum@gentoo.org> portsentry-1.1-r7.ebuild :
+
+ Fixed sed -i in first line to read ssed -i (and added -e).
*portsentry-1.1-r6 (1 Feb 2002)
diff --git a/net-analyzer/portsentry/files/digest-portsentry-1.1-r7 b/net-analyzer/portsentry/files/digest-portsentry-1.1-r7
new file mode 100644
index 000000000000..ef450b8e157a
--- /dev/null
+++ b/net-analyzer/portsentry/files/digest-portsentry-1.1-r7
@@ -0,0 +1 @@
+MD5 782839446b7eca554bb1880ef0882670 portsentry-1.1.tar.gz 45871
diff --git a/net-analyzer/portsentry/portsentry-1.1-r7.ebuild b/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
new file mode 100644
index 000000000000..6ffd3a017fd8
--- /dev/null
+++ b/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r7.ebuild,v 1.1 2002/09/27 17:53:16 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Automated port scan detector and response tool"
+HOMEPAGE="http://www.psionic.com/abacus/portsentry/"
+SRC_URI="http://www.psionic.com/tools/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="sys-apps/supersed"
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+
+ # Setting the portsentry.conf file location
+ ssed -i -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
+ portsentry_config.h
+
+ # presetting the other file locations in portsentry.conf
+ ssed -i -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
+ -e 's:^\(HISTORY_FILE\).*:\1="/etc/portsentry/portsentry.history":g' \
+ -e 's:^\(BLOCKED_FILE\).*:\1="/etc/portsentry/portsentry.blocked":g' \
+ portsentry.conf
+
+ ssed -i "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
+ ignore.csh
+}
+
+src_compile() {
+
+ make CFLAGS="${CFLAGS}" linux || die
+}
+
+src_install () {
+
+ dobin portsentry ignore.csh
+ dodoc README* CHANGES LICENSE CREDITS
+ newdoc portsentry.ignore portsentry.ignore.sample
+ newdoc portsentry.conf portsentry.conf.sample
+
+ insinto /etc/portsentry
+ newins portsentry.ignore portsentry.ignore.sample
+ newins portsentry.conf portsentry.conf.sample
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/portsentry.rc6 portsentry
+ insinto /etc/conf.d ; newins ${FILESDIR}/portsentry.confd portsentry
+}