summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-11 16:32:05 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-11 16:32:05 +0000
commit7ff14c2c255661912ac0c7ae4e62e4a3f37e26f3 (patch)
tree7307229df36258f247c3e841fab28ef7919fa422 /net-analyzer
parentSee the changelog (diff)
downloadhistorical-7ff14c2c255661912ac0c7ae4e62e4a3f37e26f3.tar.gz
historical-7ff14c2c255661912ac0c7ae4e62e4a3f37e26f3.tar.bz2
historical-7ff14c2c255661912ac0c7ae4e62e4a3f37e26f3.zip
New package
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netselect/files/digest-netselect-0.31
-rw-r--r--net-analyzer/netselect/netselect-0.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/netselect/files/digest-netselect-0.3 b/net-analyzer/netselect/files/digest-netselect-0.3
new file mode 100644
index 000000000000..c6c319950d7b
--- /dev/null
+++ b/net-analyzer/netselect/files/digest-netselect-0.3
@@ -0,0 +1 @@
+MD5 3a3714946db2458e5db3d55373057ef2 netselect-0.3.tar.gz 22047
diff --git a/net-analyzer/netselect/netselect-0.3.ebuild b/net-analyzer/netselect/netselect-0.3.ebuild
new file mode 100644
index 000000000000..906c3351e4b4
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3.ebuild,v 1.1 2002/07/11 16:32:05 stroke Exp $
+
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://www.worldvisions.ca/~apenwarr/netselect/"
+SRC_URI="http://www.worldvisions.ca/~apenwarr/netselect/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+
+newdepend /c
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ mv Makefile Makefile.orig
+ sed -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ Makefile.orig > Makefile
+ rm Makefile.orig
+
+ make || die
+}
+
+src_install () {
+ make install || die
+
+ dodoc ChangeLog HISTORY README*
+}