summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-10-11 21:20:52 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-10-11 21:20:52 +0000
commit9053f2facb773c161ccfd87acbe6e96b049291a6 (patch)
tree5e5f11c2d15b17746e742270ac205ddf8f154a44 /net-analyzer
parentRemoved sasl support as saslv2 is not fully stable yet within openldap. (diff)
downloadhistorical-9053f2facb773c161ccfd87acbe6e96b049291a6.tar.gz
historical-9053f2facb773c161ccfd87acbe6e96b049291a6.tar.bz2
historical-9053f2facb773c161ccfd87acbe6e96b049291a6.zip
version bump and sandbox fixes closes bugs #7953,8681
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog9
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.7.ebuild77
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.71
3 files changed, 86 insertions, 1 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index f81adc51fee6..5e03b9f3ef02 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.12 2002/09/15 13:35:56 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.13 2002/10/11 21:20:52 bcowan Exp $
+
+*ethereal-0.9.7 (11 Oct 2002)
+
+ 11 Oct 2002; Brad Cowan <bcowan@gentoo.org> ethereal-0.9.7.ebuild,
+ files/digest-ethereal-0.9.7 :
+
+ Version bump, fixed sandbox violation closing bugs #7953,8681
*ethereal-0.9.6 (30 Aug 2002)
diff --git a/net-analyzer/ethereal/ethereal-0.9.7.ebuild b/net-analyzer/ethereal/ethereal-0.9.7.ebuild
new file mode 100644
index 000000000000..33bc340f2596
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.9.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.7.ebuild,v 1.1 2002/10/11 21:20:52 bcowan Exp $
+
+IUSE="X ipv6 snmp ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A commercial-quality network protocol analyzer"
+SRC_URI="http://www.ethereal.com/distribution/${P}.tar.gz"
+HOMEPAGE="http://www.ethereal.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ =dev-libs/glib-1.2*
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.5 )
+ X? ( virtual/x11 =x11-libs/gtk+-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ sys-devel/bison
+ sys-devel/flex
+ >=net-libs/libpcap-0.7.1"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ # gcc related configure script braindamage
+ mv configure configure.broken
+ sed "s|-I/usr/local/include||" configure.broken > configure
+ chmod +x ./configure
+
+}
+
+src_compile() {
+ local myconf
+ use X || myconf="${myconf} --disable-ethereal"
+ use ssl || myconf="${myconf} --without-ssl"
+ use snmp || myconf="${myconf} --without-ucdsnmp"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ if use snmp
+ then addwrite "/usr/share/snmp/mibs/"
+ fi
+
+ econf \
+ --enable-pcap \
+ --enable-zlib \
+ --enable-tethereal \
+ --enable-editcap \
+ --enable-mergecap \
+ --enable-text2cap \
+ --enable-idl2eth \
+ --enable-dftest \
+ --enable-randpkt \
+ --sysconfdir=/etc/ethereal \
+ --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
+ ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/lib/ethereal/plugins/${PV}
+
+ einstall \
+ datadir=${D}/usr/share \
+ sysconfdir=${D}/etc/ethereal \
+ plugindir=${D}/usr/lib/ethereal/plugins/${PV} || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.7 b/net-analyzer/ethereal/files/digest-ethereal-0.9.7
new file mode 100644
index 000000000000..194392c48728
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.9.7
@@ -0,0 +1 @@
+MD5 c5094063c332505dd65276cf05e12c85 ethereal-0.9.7.tar.gz 4153241