summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-04-14 09:08:23 +0000
committerAlin Năstac <mrness@gentoo.org>2007-04-14 09:08:23 +0000
commit3b1316d709af437c78842f13ff02ce7816e3ab67 (patch)
tree79cbd0b429ec20ea124ad467f30c3002652b798a /net-dialup/capifwd/capifwd-0.6.3-r1.ebuild
parentRemove patch for older version too (diff)
downloadhistorical-3b1316d709af437c78842f13ff02ce7816e3ab67.tar.gz
historical-3b1316d709af437c78842f13ff02ce7816e3ab67.tar.bz2
historical-3b1316d709af437c78842f13ff02ce7816e3ab67.zip
Fix ebuild file name.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'net-dialup/capifwd/capifwd-0.6.3-r1.ebuild')
-rw-r--r--net-dialup/capifwd/capifwd-0.6.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild b/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..8ac9e8fd1bbe
--- /dev/null
+++ b/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild,v 1.1 2007/04/14 09:08:23 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="A daemon forwarding CAPI messages to capi20proxy clients"
+HOMEPAGE="http://capi20proxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/capi20proxy/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/linux-server"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/${P}-amd64.patch"
+
+ #Replace obsolete sys_errlist with strerror
+ sed -i -e 's:sys_errlist *\[ *errno *\]:strerror(errno):' \
+ src/capifwd.c src/capi/waitforsignal.c src/auth/auth.c || \
+ die "failed to replace sys_errlist"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog README
+
+ # install init-script
+ newinitd "${FILESDIR}/capifwd.init" capifwd
+ newconfd "${FILESDIR}/capifwd.conf" capifwd
+}