summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-03-12 16:07:36 +0000
committerAlin Năstac <mrness@gentoo.org>2006-03-12 16:07:36 +0000
commitcb109d4de776b5be6d8168fda3897992e8f9d489 (patch)
tree22923e1cb21bd7fcade5669656ee8b888988f249 /net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild
parentFixed LDFLAGS, gcc settings and more. See bug 125925. (diff)
downloadhistorical-cb109d4de776b5be6d8168fda3897992e8f9d489.tar.gz
historical-cb109d4de776b5be6d8168fda3897992e8f9d489.tar.bz2
historical-cb109d4de776b5be6d8168fda3897992e8f9d489.zip
Remove old version. Beutify the code of the remaining version.
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild')
-rw-r--r--net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild b/net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild
index 62bede22aeab..3a4172b515cd 100644
--- a/net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild
+++ b/net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild
@@ -1,36 +1,30 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild,v 1.4 2005/10/04 18:50:00 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/l2tpd/l2tpd-0.70_pre20031121.ebuild,v 1.5 2006/03/12 16:07:36 mrness Exp $
inherit eutils
+MY_P="l2tpd_0.70-pre20031121"
+
DESCRIPTION="Layer 2 Tunnelling Protocol Daemon"
HOMEPAGE="http://l2tpd.snapgear.org/"
-MY_P="l2tpd_0.70-pre20031121"
-S="${WORKDIR}/${P/_/-}.orig"
SRC_URI="mirror://debian/pool/main/l/l2tpd/${MY_P}.orig.tar.gz
mirror://debian/pool/main/l/l2tpd/${MY_P}-2.diff.gz"
-DEPEND="virtual/libc
- >=sys-apps/sed-4"
-
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc"
SLOT="0"
IUSE=""
+S="${WORKDIR}/${P/_/-}.orig"
+
src_unpack() {
- unpack ${MY_P}.orig.tar.gz || die
- epatch ${DISTDIR}/${MY_P}-2.diff.gz || die
+ unpack ${A}
- cd ${S} || die
+ epatch "${MY_P}-2.diff"
#Put CFLAGS from make.conf and disable builtin definition of log function
- sed -i.orig -e "s|-ggdb|${CFLAGS} -fno-builtin-log|" Makefile || die
-}
-
-src_compile() {
- emake || die
+ sed -i.orig -e "s|-ggdb|${CFLAGS} -fno-builtin-log|" "${S}/Makefile" || die "failed to change CFLAGS in Makefile"
}
src_install() {
@@ -45,6 +39,5 @@ src_install() {
newins doc/l2tp-secrets.sample l2tp-secrets
newins doc/l2tpd.conf.sample l2tpd.conf
- exeinto /etc/init.d
- newexe ${FILESDIR}/l2tpd-init l2tpd
+ newinitd "${FILESDIR}/l2tpd-init" l2tpd
}