summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-01-14 14:29:08 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-01-14 14:29:08 +0000
commit0c0a68fae637b71248cd4ac6acc58f16c5b3f109 (patch)
tree925014b39758c4c27580df52f42889a313be21b8 /net-dns/dlint
parentStable on x86. (diff)
downloadhistorical-0c0a68fae637b71248cd4ac6acc58f16c5b3f109.tar.gz
historical-0c0a68fae637b71248cd4ac6acc58f16c5b3f109.tar.bz2
historical-0c0a68fae637b71248cd4ac6acc58f16c5b3f109.zip
Use fixheadtails.eclass instead of arbitrary sed calls.
Diffstat (limited to 'net-dns/dlint')
-rw-r--r--net-dns/dlint/ChangeLog9
-rw-r--r--net-dns/dlint/Manifest14
-rw-r--r--net-dns/dlint/dlint-1.4.0-r1.ebuild9
-rw-r--r--net-dns/dlint/dlint-1.4.0.ebuild4
4 files changed, 20 insertions, 16 deletions
diff --git a/net-dns/dlint/ChangeLog b/net-dns/dlint/ChangeLog
index 604a1e6b9c28..2fdc2ba330a7 100644
--- a/net-dns/dlint/ChangeLog
+++ b/net-dns/dlint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dlint
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/ChangeLog,v 1.6 2004/10/19 14:10:26 ticho Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/ChangeLog,v 1.7 2005/01/14 14:29:08 ticho Exp $
+
+ 14 Jan 2005; Andrej Kacian <ticho@gentoo.org> dlint-1.4.0-r1.ebuild:
+ Use fixheadtails.eclass instead of arbitrary sed calls. Fix changelog.
+
+*dlint-1.4.0-r1 (19 Oct 2004)
19 Oct 2004; Andrej Kacian <ticho@gentoo.org> :
Fix deprecated use of head(1) and tail(1). Closes #67995, reported by Ray
diff --git a/net-dns/dlint/Manifest b/net-dns/dlint/Manifest
index e6df998b4e43..04918f098726 100644
--- a/net-dns/dlint/Manifest
+++ b/net-dns/dlint/Manifest
@@ -1,16 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 6e54d2acc280131e3a9a20ce998322db ChangeLog 1078
-MD5 31c1b06680bc1b1ceb6de5e3662b09e9 dlint-1.4.0.ebuild 868
-MD5 552e7f9eb455a38bbbd0bba59f1d5eda dlint-1.4.0-r1.ebuild 945
+MD5 40e417e6c92f9055820bf722a4000279 ChangeLog 1254
+MD5 a46c2f3ad1214afdc1408ef77177a3b9 dlint-1.4.0.ebuild 865
+MD5 bdeea5a11307d8ebc9854ea5493b309d dlint-1.4.0-r1.ebuild 898
MD5 0f516c20d49629e662ef970814e48522 metadata.xml 253
MD5 4885c47ebf525bab4ff5af0f22fc14c7 files/digest-dlint-1.4.0 61
MD5 4885c47ebf525bab4ff5af0f22fc14c7 files/digest-dlint-1.4.0-r1 61
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
+Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFBdSBd10xuJSrg3/sRAuSaAJ9APcgRYvQxA2L+lIDaZebuCm5zQgCeOfbS
-5c2lvZYYA6zi57vcwGnnT1Y=
-=qvlb
+iD8DBQFB59c9QlM6RnzZP+IRAjBKAJ4j8+QtJjZtUmfPPApVj6u6ZtxCXQCeLIDQ
+4PBmk4/k+QNudubHlbaMWQU=
+=f0b1
-----END PGP SIGNATURE-----
diff --git a/net-dns/dlint/dlint-1.4.0-r1.ebuild b/net-dns/dlint/dlint-1.4.0-r1.ebuild
index 4a999fd1c443..3f3d597290c8 100644
--- a/net-dns/dlint/dlint-1.4.0-r1.ebuild
+++ b/net-dns/dlint/dlint-1.4.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0-r1.ebuild,v 1.1 2004/10/19 14:10:26 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0-r1.ebuild,v 1.2 2005/01/14 14:29:08 ticho Exp $
-inherit eutils
+inherit eutils fixheadtails
S=${WORKDIR}/${P/-/}
DESCRIPTION="Dlint analyzes any DNS zone you specify, and reports any problems it finds by displaying errors and warnings"
@@ -23,8 +23,7 @@ RDEPEND="sys-apps/coreutils
src_compile() {
sed -i -e 's:rrfilt=\"/usr/local/bin/digparse\":rrfilt=\"/usr/bin/digparse\":' \
dlint
- sed -i -e "s:head -:head -n :g" dlint
- sed -i -e "s:tail +:tail -n +:g" dlint
+ ht_fix_file dlint
}
src_install () {
diff --git a/net-dns/dlint/dlint-1.4.0.ebuild b/net-dns/dlint/dlint-1.4.0.ebuild
index 4f51aeca4452..899157a8dbb3 100644
--- a/net-dns/dlint/dlint-1.4.0.ebuild
+++ b/net-dns/dlint/dlint-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0.ebuild,v 1.12 2004/07/14 23:23:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0.ebuild,v 1.13 2005/01/14 14:29:08 ticho Exp $
MY_P=${PN}${PV}
S=${WORKDIR}/${MY_P}