summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-15 01:21:47 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-15 01:21:47 +0000
commit5cca3f69df0df5f47581c070e8b9c9c853972284 (patch)
tree7b302e9adbca5a151fe15d953d4bee66fe150328 /net-dns/pdns/pdns-2.9.20-r2.ebuild
parentMark 0.6.0 0.5.1-r2 stable on ia64 (diff)
downloadhistorical-5cca3f69df0df5f47581c070e8b9c9c853972284.tar.gz
historical-5cca3f69df0df5f47581c070e8b9c9c853972284.tar.bz2
historical-5cca3f69df0df5f47581c070e8b9c9c853972284.zip
Install modules into subdirectory.
Package-Manager: portage-2.1.2_pre3-r1
Diffstat (limited to 'net-dns/pdns/pdns-2.9.20-r2.ebuild')
-rw-r--r--net-dns/pdns/pdns-2.9.20-r2.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/net-dns/pdns/pdns-2.9.20-r2.ebuild b/net-dns/pdns/pdns-2.9.20-r2.ebuild
new file mode 100644
index 000000000000..d7ae09f2bc1b
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.20-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.20-r2.ebuild,v 1.1 2006/10/15 01:21:47 swegener Exp $
+
+inherit multilib eutils autotools
+
+DESCRIPTION="The PowerDNS Daemon"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ldap mysql postgres sqlite static tdb"
+
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )
+ sqlite? ( =dev-db/sqlite-2.8* )
+ tdb? ( dev-libs/tdb )
+ >=dev-libs/boost-1.31"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/2.9.18-default-mysql-options.patch
+ epatch "${FILESDIR}"/2.9.20-ldap-deprecated.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ local modules="pipe geo" myconf=""
+
+ use mysql && modules="${modules} gmysql"
+ use postgres && modules="${modules} gpgsql"
+ use sqlite && modules="${modules} gsqlite"
+ use ldap && modules="${modules} ldap"
+ use tdb && modules="${modules} xdb"
+ use debug && myconf="${myconf} --enable-verbose-logging"
+
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --disable-recursor \
+ --with-modules= \
+ --with-dynmodules="${modules}" \
+ --with-pgsql-includes=/usr/include \
+ --with-pgsql-lib=/usr/$(get_libdir) \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-sqlite-lib=/usr/$(get_libdir) \
+ $(use_enable static static-binaries) \
+ ${myconf} \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use doc
+ then
+ emake -C codedocs codedocs || die "emake codedocs failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ doinitd "${FILESDIR}"/pdns
+
+ dodoc ChangeLog README TODO
+ use doc && dohtml -r codedocs/html/.
+}
+
+pkg_preinst() {
+ enewgroup pdns
+ enewuser pdns -1 -1 /var/empty pdns
+}
+
+pkg_postinst() {
+ einfo
+ einfo "PowerDNS provides multiple instances support. You can create more instances"
+ einfo "by symlinking the pdns init script to another name."
+ einfo
+ einfo "The name must be in the format pdns-<suffix> and PowerDNS will use the"
+ einfo "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+ einfo
+}