summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-05-07 18:46:10 +0000
committerSven Wegener <swegener@gentoo.org>2008-05-07 18:46:10 +0000
commit6e7125719de3fa63adf560297a4985f50dd30d1e (patch)
treeff56ef90f3b9b40d223324fd05b2ef55080e60b6 /net-dns/pdns/pdns-2.9.20-r2.ebuild
parentCleanup. (diff)
downloadhistorical-6e7125719de3fa63adf560297a4985f50dd30d1e.tar.gz
historical-6e7125719de3fa63adf560297a4985f50dd30d1e.tar.bz2
historical-6e7125719de3fa63adf560297a4985f50dd30d1e.zip
Cleanup.
Package-Manager: portage-2.1.5_rc7
Diffstat (limited to 'net-dns/pdns/pdns-2.9.20-r2.ebuild')
-rw-r--r--net-dns/pdns/pdns-2.9.20-r2.ebuild101
1 files changed, 0 insertions, 101 deletions
diff --git a/net-dns/pdns/pdns-2.9.20-r2.ebuild b/net-dns/pdns/pdns-2.9.20-r2.ebuild
deleted file mode 100644
index 31add4821c5c..000000000000
--- a/net-dns/pdns/pdns-2.9.20-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.20-r2.ebuild,v 1.5 2007/05/06 09:16:12 genone Exp $
-
-inherit multilib eutils autotools
-
-DESCRIPTION="The PowerDNS Daemon"
-SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
-HOMEPAGE="http://www.powerdns.com/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc ldap mysql postgres sqlite static tdb opendbx"
-
-DEPEND="mysql? ( virtual/mysql )
- postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
- ldap? ( >=net-nds/openldap-2.0.27-r4 )
- sqlite? ( =dev-db/sqlite-2.8* )
- opendbx? ( dev-db/opendbx )
- tdb? ( dev-libs/tdb )
- >=dev-libs/boost-1.31"
-
-RDEPEND="${DEPEND}"
-
-DEPEND="${DEPEND}
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/2.9.18-default-mysql-options.patch
- epatch "${FILESDIR}"/2.9.20-ldap-deprecated.patch
-
- eautoreconf
-}
-
-src_compile() {
- local modules="pipe geo" myconf=""
-
- use mysql && modules="${modules} gmysql"
- use postgres && modules="${modules} gpgsql"
- use sqlite && modules="${modules} gsqlite"
- use opendbx && modules="${modules} opendbx"
- use ldap && modules="${modules} ldap"
- use tdb && modules="${modules} xdb"
- use debug && myconf="${myconf} --enable-verbose-logging"
-
- econf \
- --sysconfdir=/etc/powerdns \
- --libdir=/usr/$(get_libdir)/powerdns \
- --disable-recursor \
- --with-modules= \
- --with-dynmodules="${modules}" \
- --with-pgsql-includes=/usr/include \
- --with-pgsql-lib=/usr/$(get_libdir) \
- --with-mysql-lib=/usr/$(get_libdir) \
- --with-sqlite-lib=/usr/$(get_libdir) \
- $(use_enable static static-binaries) \
- ${myconf} \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use doc
- then
- emake -C codedocs codedocs || die "emake codedocs failed"
- fi
-}
-
-src_install () {
- make DESTDIR="${D}" install || die "make install failed"
-
- mv "${D}"/etc/powerdns/pdns.conf{-dist,}
-
- # set defaults: setuid=pdns, setgid=pdns
- sed -i \
- -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
- "${D}"/etc/powerdns/pdns.conf
-
- doinitd "${FILESDIR}"/pdns
-
- keepdir /var/empty
-
- dodoc ChangeLog README TODO
- use doc && dohtml -r codedocs/html/.
-}
-
-pkg_preinst() {
- enewgroup pdns
- enewuser pdns -1 -1 /var/empty pdns
-}
-
-pkg_postinst() {
- elog
- elog "PowerDNS provides multiple instances support. You can create more instances"
- elog "by symlinking the pdns init script to another name."
- elog
- elog "The name must be in the format pdns-<suffix> and PowerDNS will use the"
- elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
- elog
-}