summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-17 08:46:08 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-17 08:46:08 +0000
commita1f4a863b38f1e71eb968c250b59a156ace9003c (patch)
tree880c18c0c518d56023f6d5e72b226e8b2878211b /net-dns/pdns
parentcleanup (diff)
downloadhistorical-a1f4a863b38f1e71eb968c250b59a156ace9003c.tar.gz
historical-a1f4a863b38f1e71eb968c250b59a156ace9003c.tar.bz2
historical-a1f4a863b38f1e71eb968c250b59a156ace9003c.zip
Added a small patch that makes pdns load the default mysql options from my.cnf.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/ChangeLog6
-rw-r--r--net-dns/pdns/Manifest11
-rw-r--r--net-dns/pdns/files/2.9.18-default-mysql-options.patch13
-rw-r--r--net-dns/pdns/pdns-2.9.18.ebuild13
4 files changed, 35 insertions, 8 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index c00d8ad79d4e..a57250eac2f1 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/pdns
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.16 2005/07/17 04:50:51 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.17 2005/07/17 08:46:07 swegener Exp $
+
+ 17 Jul 2005; Sven Wegener <swegener@gentoo.org>
+ +files/2.9.18-default-mysql-options.patch, pdns-2.9.18.ebuild:
+ Added a small patch that makes pdns load the default mysql options from my.cnf.
*pdns-2.9.18 (17 Jul 2005)
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 7b51d521184d..aba003dbf5fe 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,7 +1,8 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 0ebb85e67da1eda32defbb9ca7563254 ChangeLog 2543
+MD5 198d9ae48b583b7946b3042e7e61d2cf ChangeLog 2741
+MD5 90fb32e843326d14359c508cef855929 files/2.9.18-default-mysql-options.patch 606
MD5 62a8267bd54fd7edf57908299088c96a files/digest-pdns-2.9.17 63
MD5 e59bb419d93a7d7bdcb13764c57b3f6d files/digest-pdns-2.9.18 63
MD5 60d7355f48410a77e8df555a089025cb files/pdns 889
@@ -10,11 +11,11 @@ MD5 558969af8e34a040723147fe14a53a44 files/precursor 488
MD5 bbb2b0b25869b840d8fa2d242a8b20c2 files/recursor.conf 392
MD5 56567ddcaf248499457a1ce74277c910 metadata.xml 573
MD5 172c916f2af3e12be9af6f65bc4ab881 pdns-2.9.17.ebuild 1313
-MD5 fae7bde2896ef25204d424b717e303d9 pdns-2.9.18.ebuild 2181
+MD5 e02555c51fe6d90595a6119264df1ad6 pdns-2.9.18.ebuild 2301
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC2ev1I1lqEGTUzyQRAhXPAJ9a61Q2IbBjjKMzUAPqi3ZPwSPliwCfbcgt
-wsWmjlAYFdpNWQzgzjjyKsg=
-=T001
+iD8DBQFC2hroI1lqEGTUzyQRAoloAKCGKmlfwBOUOYMaWpSaGTlcrmyRMwCgie/M
+v2NtH8E06CWLRcVLkL+ZUwM=
+=NSax
-----END PGP SIGNATURE-----
diff --git a/net-dns/pdns/files/2.9.18-default-mysql-options.patch b/net-dns/pdns/files/2.9.18-default-mysql-options.patch
new file mode 100644
index 000000000000..a9048e13e10d
--- /dev/null
+++ b/net-dns/pdns/files/2.9.18-default-mysql-options.patch
@@ -0,0 +1,13 @@
+diff -Nur pdns-2.9.18.orig/modules/gmysqlbackend/smysql.cc pdns-2.9.18/modules/gmysqlbackend/smysql.cc
+--- pdns-2.9.18.orig/modules/gmysqlbackend/smysql.cc 2005-04-23 23:40:15.000000000 +0200
++++ pdns-2.9.18/modules/gmysqlbackend/smysql.cc 2005-07-17 10:38:35.363597586 +0200
+@@ -15,6 +15,9 @@
+ const string &password)
+ {
+ mysql_init(&d_db);
++#if MYSQL_VERSION_ID > 32349
++ mysql_options(&d_db, MYSQL_READ_DEFAULT_GROUP, "client");
++#endif
+ if (!mysql_real_connect(&d_db, host.empty() ? 0 : host.c_str(),
+ user.empty() ? 0 : user.c_str(),
+ password.empty() ? 0 : password.c_str(),
diff --git a/net-dns/pdns/pdns-2.9.18.ebuild b/net-dns/pdns/pdns-2.9.18.ebuild
index 1f0dde68b238..0e1c6670ccd5 100644
--- a/net-dns/pdns/pdns-2.9.18.ebuild
+++ b/net-dns/pdns/pdns-2.9.18.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.18.ebuild,v 1.2 2005/07/17 05:05:48 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.18.ebuild,v 1.3 2005/07/17 08:46:07 swegener Exp $
+
+inherit eutils
DESCRIPTION="The PowerDNS Daemon"
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
@@ -14,7 +16,7 @@ DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
ldap? ( >=net-nds/openldap-2.0.27-r4 )
sqlite? ( =dev-db/sqlite-2.8* )
- recursor? ( dev-libs/boost )
+ recursor? ( >=dev-libs/boost-1.31 )
tdb? ( dev-libs/tdb )"
RDEPEND="${DEPEND}"
@@ -22,6 +24,13 @@ RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
doc? ( app-doc/doxygen )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/${PV}-default-mysql-options.patch
+}
+
src_compile() {
local modules="pipe geo" myconf=""