summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-06-02 16:03:31 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-06-02 16:03:31 +0000
commit4ee6775cd64e944e5a72a6b4b8384340dfbbecab (patch)
treed16a2da41c0303ccbe4643866bbf191a19fdb3f4 /net-fs/samba/samba-3.5.3.ebuild
parentAdd live version, by Anders Bach Madsen <abachn@daimi.au.dk> in bug #320919 (diff)
downloadhistorical-4ee6775cd64e944e5a72a6b4b8384340dfbbecab.tar.gz
historical-4ee6775cd64e944e5a72a6b4b8384340dfbbecab.tar.bz2
historical-4ee6775cd64e944e5a72a6b4b8384340dfbbecab.zip
Adding support for winbind shared modules idmap_rid , idmap_ad and idmap_ldap bug #301968
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'net-fs/samba/samba-3.5.3.ebuild')
-rw-r--r--net-fs/samba/samba-3.5.3.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-fs/samba/samba-3.5.3.ebuild b/net-fs/samba/samba-3.5.3.ebuild
index 66a758def464..13fadb5c0113 100644
--- a/net-fs/samba/samba-3.5.3.ebuild
+++ b/net-fs/samba/samba-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.3.ebuild,v 1.5 2010/06/01 14:04:59 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.3.ebuild,v 1.6 2010/06/02 16:03:31 vostorga Exp $
EAPI="2"
@@ -51,6 +51,7 @@ SBINPROGS=""
BINPROGS=""
KRBPLUGIN=""
PLUGINEXT=".so"
+SHAREDMODS=""
if use server ; then
SBINPROGS="${SBINPROGS} bin/smbd bin/nmbd"
@@ -72,7 +73,13 @@ fi
use cups && BINPROGS="${BINPROGS} bin/smbspool"
use ldb && BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename";
-use winbind && BINPROGS="${BINPROGS} bin/wbinfo"
+
+if use winbind ; then
+ BINPROGS="${BINPROGS} bin/wbinfo"
+ SHAREDMODS="${SHAREDMODS}idmap_rid"
+ use ads && SHAREDMODS="${SHAREDMODS},idmap_ad"
+ use ldap && SHAREDMODS="${SHAREDMODS},idmap_ldap"
+fi
S="${WORKDIR}/${MY_P}/source3"
@@ -178,6 +185,7 @@ src_configure() {
$(use_with aio aio-support) \
--with-sendfile-support \
$(use_with winbind) \
+ --with-shared-modules=${SHAREDMODS} \
--without-included-popt \
--without-included-iniparser
}