summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-18 20:50:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-18 20:50:36 +0000
commit9a37a41c413e8dc0e7dce31b3d348b9a865b1f89 (patch)
treeb132aceb3ad321329dcd896a5681bd638227431f /net-ftp/atftp
parentold (diff)
downloadhistorical-9a37a41c413e8dc0e7dce31b3d348b9a865b1f89.tar.gz
historical-9a37a41c413e8dc0e7dce31b3d348b9a865b1f89.tar.bz2
historical-9a37a41c413e8dc0e7dce31b3d348b9a865b1f89.zip
add support for USE=selinux #106354 by petre rodan
Package-Manager: portage-2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/
Diffstat (limited to 'net-ftp/atftp')
-rw-r--r--net-ftp/atftp/Manifest24
-rw-r--r--net-ftp/atftp/atftp-0.7.ebuild15
2 files changed, 24 insertions, 15 deletions
diff --git a/net-ftp/atftp/Manifest b/net-ftp/atftp/Manifest
index f955e05d532f..2dd26bfbc230 100644
--- a/net-ftp/atftp/Manifest
+++ b/net-ftp/atftp/Manifest
@@ -1,11 +1,19 @@
-MD5 a483bfda64ff5f38d280ac88fa3206d8 ChangeLog 2702
-MD5 a8c1eb8d7148ed58420b5586a1296350 atftp-0.6-r3.ebuild 988
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 4cd5fb4b7755c4d8f992f3c56a615141 atftp-0.7.ebuild 963
MD5 6f53cf043ccea8c37c9bba4d68703c16 atftp-0.6.2.ebuild 1039
-MD5 53703484e7401f1c8580e8e391091c72 atftp-0.7.ebuild 910
-MD5 ef1244d13cccdfbe2dff44442e0c3d1f files/atftp-0.6-security.patch 1019
-MD5 0adc9648a64aa6a05a55bf822eec7265 files/atftp-0.7-gcc.patch 540
-MD5 939f5bfbb9b7a728330cc124175c39e3 files/atftp.confd 105
-MD5 f3d1e03f8ce70ea8ed775de7407304f3 files/atftp.init 437
-MD5 6edbe26f81fbd488b6fbffd1bbd27ca9 files/digest-atftp-0.6-r3 61
+MD5 a483bfda64ff5f38d280ac88fa3206d8 ChangeLog 2702
MD5 e14c6bca387e9af7d2734fb9f08a67ee files/digest-atftp-0.6.2 63
+MD5 f3d1e03f8ce70ea8ed775de7407304f3 files/atftp.init 437
+MD5 939f5bfbb9b7a728330cc124175c39e3 files/atftp.confd 105
+MD5 0adc9648a64aa6a05a55bf822eec7265 files/atftp-0.7-gcc.patch 540
+MD5 ef1244d13cccdfbe2dff44442e0c3d1f files/atftp-0.6-security.patch 1019
MD5 401c2182f70ea502b2b13567dee9daf9 files/digest-atftp-0.7 61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDLdM+gIKl8Uu19MoRAksJAJ9vTPce+baVdD17oTOVVQ82qBRaxACfRTVV
+WNiYRplQCiBa5ARtPz0aE5w=
+=HSU4
+-----END PGP SIGNATURE-----
diff --git a/net-ftp/atftp/atftp-0.7.ebuild b/net-ftp/atftp/atftp-0.7.ebuild
index 1c63c3357ef7..06ecf0056021 100644
--- a/net-ftp/atftp/atftp-0.7.ebuild
+++ b/net-ftp/atftp/atftp-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/atftp-0.7.ebuild,v 1.3 2005/07/21 14:42:43 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/atftp-0.7.ebuild,v 1.4 2005/09/18 20:50:36 vapier Exp $
inherit eutils
@@ -10,17 +10,18 @@ SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 arm ~ppc ppc64 ~sparc ~x86"
-IUSE="tcpd"
+KEYWORDS="~amd64 arm ~ppc ppc64 ~sparc x86"
+IUSE="selinux tcpd"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ selinux? ( sec-policy/selinux-tftpd )
!virtual/tftp"
PROVIDE="virtual/tftp"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc.patch
}
src_compile() {
@@ -30,6 +31,6 @@ src_compile() {
src_install() {
make install DESTDIR="${D}" || die "Installation failed"
- newinitd ${FILESDIR}/atftp.init atftp
- newconfd ${FILESDIR}/atftp.confd atftp
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
}