summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-28 05:24:13 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-28 05:24:13 +0000
commit2976aa64c576eb5d76d265f70f3a9097dfdeb3ac (patch)
treedc5a008a22e16e21bc4ea4f991bba0890fae4a1b /net-ftp
parentAdded DarcNES a multi-system emulator (diff)
downloadhistorical-2976aa64c576eb5d76d265f70f3a9097dfdeb3ac.tar.gz
historical-2976aa64c576eb5d76d265f70f3a9097dfdeb3ac.tar.bz2
historical-2976aa64c576eb5d76d265f70f3a9097dfdeb3ac.zip
Dependencie fixes
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftp/ftp-0.17-r1.ebuild10
-rw-r--r--net-ftp/ncftp/ncftp-3.0.2.ebuild8
2 files changed, 8 insertions, 10 deletions
diff --git a/net-ftp/ftp/ftp-0.17-r1.ebuild b/net-ftp/ftp/ftp-0.17-r1.ebuild
index 2b0d84778664..0038040a0220 100644
--- a/net-ftp/ftp/ftp-0.17-r1.ebuild
+++ b/net-ftp/ftp/ftp-0.17-r1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r1.ebuild,v 1.3 2000/11/01 04:44:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r1.ebuild,v 1.4 2001/05/28 05:24:13 achim Exp $
-P=ftp-0.17
A=netkit-${P}.tar.gz
S=${WORKDIR}/netkit-${P}
DESCRIPTION="Standard Linux FTP client"
SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${A}"
-DEPEND=">=sys-libs/glibc-2.1.3
- >=sys-libs/gpm-1.19.3
- >=sys-libs/ncurses-5.1"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2"
src_compile() {
- cd ${S}
+
try ./configure --prefix=/usr
cp MCONFIG MCONFIG.orig
sed -e "s/-pipe -O2/${CFLAGS}/" MCONFIG.orig > MCONFIG
diff --git a/net-ftp/ncftp/ncftp-3.0.2.ebuild b/net-ftp/ncftp/ncftp-3.0.2.ebuild
index 9d1126fbf14c..bfd63fda28b0 100644
--- a/net-ftp/ncftp/ncftp-3.0.2.ebuild
+++ b/net-ftp/ncftp/ncftp-3.0.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.0.2.ebuild,v 1.2 2000/12/22 17:51:19 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.0.2.ebuild,v 1.3 2001/05/28 05:24:13 achim Exp $
A=${P}-src.tar.gz
S=${WORKDIR}/${P}
@@ -9,16 +9,16 @@ DESCRIPTION="An extremely configurable ftp client"
SRC_URI="ftp://ftp.ncftp.com/ncftp/${A}"
HOMEPAGE="http://www.ncftp.com/"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2"
src_compile() {
- cd ${S}
+
try ./configure --prefix=/usr --host=${CHOST}
try make
}
src_install () {
- cd ${S}
+
try make prefix=${D}/usr install
dodoc CHANGELOG FIREWALL-PROXY-README LICENSE.txt