summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-29 03:11:43 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-29 03:11:43 +0000
commit03c1a427ac25bd0356bfb337eaf796b70346a147 (patch)
treed334ef93e717e94674dbea0cf1bbdef73b1a923f /net-im/gaim-cvs
parentblah (diff)
downloadhistorical-03c1a427ac25bd0356bfb337eaf796b70346a147.tar.gz
historical-03c1a427ac25bd0356bfb337eaf796b70346a147.tar.bz2
historical-03c1a427ac25bd0356bfb337eaf796b70346a147.zip
Added --prefix=/usr per #9862
Diffstat (limited to 'net-im/gaim-cvs')
-rw-r--r--net-im/gaim-cvs/ChangeLog7
-rw-r--r--net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r20
-rw-r--r--net-im/gaim-cvs/gaim-cvs-0.60-r2.ebuild56
3 files changed, 62 insertions, 1 deletions
diff --git a/net-im/gaim-cvs/ChangeLog b/net-im/gaim-cvs/ChangeLog
index f6ba27da61ed..1787ff9cde13 100644
--- a/net-im/gaim-cvs/ChangeLog
+++ b/net-im/gaim-cvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim-cvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/ChangeLog,v 1.5 2002/10/28 16:53:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/ChangeLog,v 1.6 2002/10/29 03:11:43 vapier Exp $
+
+*gaim-cvs-0.60-r1 (28 Oct 2002)
+
+ 28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added --prefix=/usr per #9862
*gaim-cvs-0.60-r1 (25 Oct 2002)
diff --git a/net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r2 b/net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r2
diff --git a/net-im/gaim-cvs/gaim-cvs-0.60-r2.ebuild b/net-im/gaim-cvs/gaim-cvs-0.60-r2.ebuild
new file mode 100644
index 000000000000..e85d6e4246e6
--- /dev/null
+++ b/net-im/gaim-cvs/gaim-cvs-0.60-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/gaim-cvs-0.60-r2.ebuild,v 1.1 2002/10/29 03:11:43 vapier Exp $
+
+IUSE="nas nls esd arts perl"
+
+DESCRIPTION="GTK Instant Messenger client - CVS ebuild."
+HOMEPAGE="http://gaim.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ !net-im/gaim
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ esd? ( >=media-sound/esound-0.2.22-r2 )
+ nls? ( sys-devel/gettext )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ arts? ( >=kde-base/arts-0.9.5 )
+ perl? ( >=sys-devel/perl-5.6.1 )"
+
+inherit cvs
+
+ECVS_SERVER="cvs.gaim.sourceforge.net:/cvsroot/gaim"
+ECVS_MODULE="gaim"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_compile() {
+ local myconf="--prefix=/usr"
+
+ use esd || myconf="--disable-esd"
+ use perl || myconf="${myconf} --disable-perl"
+ use nas && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ if [ "` use arts`" ]; then
+ inherit kde-functions
+ set-kdedir 3
+ # $KDEDIR now points to arts location
+ else
+ myconf="${myconf} --disable-artsc"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./autogen.sh ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO
+}