summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-17 09:08:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-17 09:08:10 +0000
commit4a0398cb924dd5f1b4d413a7eed56f4dcc5f1be7 (patch)
tree5dd75c4ea615e5929e66f78d53eea5d4b3e8d808 /net-im/gtk+licq
parentlicq-console masked (diff)
downloadhistorical-4a0398cb924dd5f1b4d413a7eed56f4dcc5f1be7.tar.gz
historical-4a0398cb924dd5f1b4d413a7eed56f4dcc5f1be7.tar.bz2
historical-4a0398cb924dd5f1b4d413a7eed56f4dcc5f1be7.zip
repoman'd
Diffstat (limited to 'net-im/gtk+licq')
-rw-r--r--net-im/gtk+licq/gtk+licq-0.51-r2.ebuild73
1 files changed, 32 insertions, 41 deletions
diff --git a/net-im/gtk+licq/gtk+licq-0.51-r2.ebuild b/net-im/gtk+licq/gtk+licq-0.51-r2.ebuild
index 9965e88d2f80..1b7d068cc6f6 100644
--- a/net-im/gtk+licq/gtk+licq-0.51-r2.ebuild
+++ b/net-im/gtk+licq/gtk+licq-0.51-r2.ebuild
@@ -1,58 +1,49 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gtk+licq/gtk+licq-0.51-r2.ebuild,v 1.5 2002/07/11 06:30:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gtk+licq/gtk+licq-0.51-r2.ebuild,v 1.6 2002/07/17 09:08:08 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GTK+ interface for Licq, the KDE/QT ICQ client"
SRC_URI="http://gtk.licq.org/download/${P}.tar.gz"
HOMEPAGE="http://gtk.licq.org"
-SLOT="0"
-DEPEND="virtual/glibc
- sys-devel/perl
- nls? ( sys-devel/gettext )
- >=net-im/licq-1.0.2
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 )
- =x11-libs/gtk+-1.2*
- spell? ( >=app-text/pspell-0.11.2 )"
-RDEPEND="virtual/glibc
- >=net-im/licq-1.0.2
- =x11-libs/gtk+-1.2*
+DEPEND="sys-devel/perl
+ =x11-libs/gtk+-1.2*
+ >=net-im/licq-1.0.2
gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 )
- spell? ( >=app-text/pspell-0.11.2 )"
+ spell? ( >=app-text/pspell-0.11.2 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
src_compile() {
- local myconf
- local myprefix
- myprefix="/usr"
- if [ -z "`use gnome`" ] ; then
- myconf="--disable-gnome"
- fi
- if [ -z "`use spell`" ] ; then
- myconf="$myconf --disable-pspell"
- fi
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- fi
-
- CXXFLAGS="${CXXFLAGS} `orbit-config --cflags client`"
-
- ./configure --host=${CHOST} --prefix=${myprefix} \
- --with-licq-includes=/usr/include/licq \
- ${myconf} || die
+
+ local myconf
+ local myprefix
+
+ use gnome || myconf="--disable-gnome"
+ use spell || myconf="$myconf --disable-pspell"
+ use nls || myconf="${myconf} --disable-nls"
+
+ CXXFLAGS="${CXXFLAGS} `orbit-config --cflags client`"
+
+ econf \
+ --with-licq-includes=/usr/include/licq \
+ ${myconf} || die
- emake || die
+ emake || die
}
src_install() {
- local myprefix
- myprefix="usr"
- make prefix=${D}/${myprefix} install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
- mkdir -p ${D}/usr/lib/licq
- cd ${D}/usr/lib/licq
- ls ../../../${myprefix}/lib/licq
- ln -s ../../../${myprefix}/lib/licq/* .
+ local myprefix
+ myprefix="usr"
+ make prefix=${D}/${myprefix} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ mkdir -p ${D}/usr/lib/licq
+ cd ${D}/usr/lib/licq
+ ls ../../../${myprefix}/lib/licq
+ ln -s ../../../${myprefix}/lib/licq/* .
}