summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-28 12:06:03 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-28 12:06:03 +0000
commite180ae84e63b8346373e5755829262854c13594c (patch)
tree3fad54d0d97767f5e1af8ce1415fc7339df6487f /net-im/ktp-text-ui
parentInitial import, based on the work of avx on bug 432954. (diff)
downloadhistorical-e180ae84e63b8346373e5755829262854c13594c.tar.gz
historical-e180ae84e63b8346373e5755829262854c13594c.tar.bz2
historical-e180ae84e63b8346373e5755829262854c13594c.zip
Version bump KDE Telepathy 0.5.0.
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'net-im/ktp-text-ui')
-rw-r--r--net-im/ktp-text-ui/ChangeLog7
-rw-r--r--net-im/ktp-text-ui/ktp-text-ui-0.5.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-im/ktp-text-ui/ChangeLog b/net-im/ktp-text-ui/ChangeLog
index 5f9bdef8c786..7534daab19bd 100644
--- a/net-im/ktp-text-ui/ChangeLog
+++ b/net-im/ktp-text-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/ktp-text-ui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-text-ui/ChangeLog,v 1.7 2012/07/26 12:28:54 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-text-ui/ChangeLog,v 1.8 2012/08/28 12:06:03 johu Exp $
+
+*ktp-text-ui-0.5.0 (28 Aug 2012)
+
+ 28 Aug 2012; Johannes Huber <johu@gentoo.org> +ktp-text-ui-0.5.0.ebuild:
+ Version bump KDE Telepathy 0.5.0.
*ktp-text-ui-0.4.1 (26 Jul 2012)
diff --git a/net-im/ktp-text-ui/ktp-text-ui-0.5.0.ebuild b/net-im/ktp-text-ui/ktp-text-ui-0.5.0.ebuild
new file mode 100644
index 000000000000..4ffb3052e274
--- /dev/null
+++ b/net-im/ktp-text-ui/ktp-text-ui-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-text-ui/ktp-text-ui-0.5.0.ebuild,v 1.1 2012/08/28 12:06:03 johu Exp $
+
+EAPI=4
+
+KDE_LINGUAS="ca cs da de el es et fi fr ga gl hu it ja km lt nb nds nl pl pt
+pt_BR ru sk sr sr@ijekavian sr@ijekavianlatin sr@latin sv ug uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="http://community.kde.org/Real-Time_Communication_and_Collaboration"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/unstable/kde-telepathy/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug +history"
+
+DEPEND="
+ >=net-libs/telepathy-qt-0.9.3
+ history? ( >=net-libs/telepathy-logger-qt-0.5.0 )
+"
+RDEPEND="${DEPEND}
+ >=net-im/ktp-contact-list-${PV}
+"
+
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with history TelepathyLoggerQt4)
+ )
+
+ cmake-utils_src_configure
+}