summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-02-26 01:16:28 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-02-26 01:16:28 +0000
commitd5435a4da9177ef000960f116340efc9a40c9ccb (patch)
treef42f7d3701fe9450a2f6f9ffc3fee02a3226f652 /net-irc/conspire/conspire-0.13.1.ebuild
parentMark stable on AMD64, PPC & X86. Tested on a Core 2 Duo T7700, PowerBook5,9 a... (diff)
downloadhistorical-d5435a4da9177ef000960f116340efc9a40c9ccb.tar.gz
historical-d5435a4da9177ef000960f116340efc9a40c9ccb.tar.bz2
historical-d5435a4da9177ef000960f116340efc9a40c9ccb.zip
Version bump. Mark 0.12.0 stable on X86.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-irc/conspire/conspire-0.13.1.ebuild')
-rw-r--r--net-irc/conspire/conspire-0.13.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-irc/conspire/conspire-0.13.1.ebuild b/net-irc/conspire/conspire-0.13.1.ebuild
new file mode 100644
index 000000000000..d3cebe274868
--- /dev/null
+++ b/net-irc/conspire/conspire-0.13.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-0.13.1.ebuild,v 1.1 2008/02/26 01:16:28 chainsaw Exp $
+
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="python gnutls ipv6 nls mmx socks5"
+DEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libsexy"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-0.60
+ nls? ( dev-util/intltool )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}