summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-17 12:37:06 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-17 12:37:06 +0000
commitd011cc926375d3086eb17da8d066b427c7b0fe05 (patch)
tree83b9734f5930e24cc2649e5644c074faa40b42d1 /net-irc/ircii/ircii-20060725.ebuild
parentx86 stable wrt bug 164031 (diff)
downloadhistorical-d011cc926375d3086eb17da8d066b427c7b0fe05.tar.gz
historical-d011cc926375d3086eb17da8d066b427c7b0fe05.tar.bz2
historical-d011cc926375d3086eb17da8d066b427c7b0fe05.zip
version bump, bug 166947
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'net-irc/ircii/ircii-20060725.ebuild')
-rw-r--r--net-irc/ircii/ircii-20060725.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-irc/ircii/ircii-20060725.ebuild b/net-irc/ircii/ircii-20060725.ebuild
new file mode 100644
index 000000000000..cf847cf5732d
--- /dev/null
+++ b/net-irc/ircii/ircii-20060725.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ircii/ircii-20060725.ebuild,v 1.1 2007/02/17 12:37:06 armin76 Exp $
+
+IUSE="ipv6"
+
+DESCRIPTION="ircII is an IRC and ICB client that runs under most UNIX platforms."
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2"
+HOMEPAGE="http://www.eterna.com.au/ircii/"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+
+src_compile() {
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp \
+ || die "dodoc failed"
+}