summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-12-13 01:28:44 +0000
committerNed Ludd <solar@gentoo.org>2003-12-13 01:28:44 +0000
commitb68817fc4ba920e0f3d61ac1a280e2ba4776304c (patch)
treea62b3a2d4a112078f0d57f465a6035c99db8640f /net-irc
parentfix denial of service bug in dcc.c (diff)
downloadhistorical-b68817fc4ba920e0f3d61ac1a280e2ba4776304c.tar.gz
historical-b68817fc4ba920e0f3d61ac1a280e2ba4776304c.tar.bz2
historical-b68817fc4ba920e0f3d61ac1a280e2ba4776304c.zip
fix denial of service bug in dcc.c
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/Manifest4
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.6-r11
-rw-r--r--net-irc/xchat/files/xchat-2.0.6-fix_dccsend.patch14
-rw-r--r--net-irc/xchat/xchat-2.0.6-r1.ebuild91
4 files changed, 108 insertions, 2 deletions
diff --git a/net-irc/xchat/Manifest b/net-irc/xchat/Manifest
index b10c6aa3ebbe..68d1ad7f91fe 100644
--- a/net-irc/xchat/Manifest
+++ b/net-irc/xchat/Manifest
@@ -1,6 +1,6 @@
-MD5 a58b095ce7a096e3a353b585e36bc59c ChangeLog 10553
+MD5 3de3bfb62a31474e8abe774bac899017 ChangeLog 10718
MD5 fb5772136a872c08434566d4f0bcdc7f metadata.xml 179
-MD5 a24ce95cd73d67eedd69b1e22a641036 xchat-2.0.6-r1.ebuild 2386
+MD5 a5a54730a6d8f16d32f25f6e9237f807 xchat-2.0.6-r1.ebuild 2390
MD5 4887bbd6f7df0f18b5aebc93850c6cf4 xchat-1.8.11.ebuild 2213
MD5 49bc450041164b33decb74774522afab xchat-2.0.6.ebuild 1987
MD5 b424d2740a1f93cdc3f306461b4cf778 xchat-2.0.1.ebuild 1946
diff --git a/net-irc/xchat/files/digest-xchat-2.0.6-r1 b/net-irc/xchat/files/digest-xchat-2.0.6-r1
new file mode 100644
index 000000000000..89a4b9ec84bc
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.0.6-r1
@@ -0,0 +1 @@
+MD5 5cc5e603083242fb598bc940b1a4fccc xchat-2.0.6.tar.bz2 942837
diff --git a/net-irc/xchat/files/xchat-2.0.6-fix_dccsend.patch b/net-irc/xchat/files/xchat-2.0.6-fix_dccsend.patch
new file mode 100644
index 000000000000..37f54b981fff
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.0.6-fix_dccsend.patch
@@ -0,0 +1,14 @@
+--- src/common/dcc.c.orig 2003-12-12 16:49:28.523536903 -0800
++++ src/common/dcc.c 2003-12-12 16:50:50.339644657 -0800
+@@ -1659,6 +1659,11 @@
+ * sending file.
+ */
+ dcc = find_dcc_from_id (pasvid, TYPE_SEND);
++ /* defensive check for malformed requests */
++ if( dcc == NULL ) {
++ dcc_malformed( sess, nick, word_eol[4] + 2 );
++ return;
++ }
+ dcc->addr = addr;
+ dcc->port = port;
+ dcc_connect(dcc);
diff --git a/net-irc/xchat/xchat-2.0.6-r1.ebuild b/net-irc/xchat/xchat-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..e848054935f3
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.6-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.6-r1.ebuild,v 1.1 2003/12/13 01:28:41 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+IUSE="perl tcltk python ssl mmx ipv6 nls"
+# Local use flag for the text frontend (bug #26427)
+IUSE="${IUSE} xchattext xchatnogtk"
+
+# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+if [ ${ARCH} = "sparc" ]
+then
+ replace-flags "-O3" "-O2"
+fi
+
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+src_compile() {
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ # test for local usage of xchatnogtk
+ local gtkconf
+ use xchatnogtk \
+ && gtkconf="--disable-gtkfe" \
+ || gtkconf="--enable-gtkfe"
+
+ econf \
+ ${gtkconf} \
+ `use_enable ssl openssl` \
+ `use_enable perl` \
+ `use_enable python` \
+ `use_enable tcltk tcl` \
+ `use_enable mmx` \
+ `use_enable ipv6` \
+ `use_enable nls` \
+ `use_enable xchattext textfe` \
+ --program-suffix=-2 \
+ || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+
+}
+
+src_install() {
+
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h
+
+ dodoc AUTHORS COPYING ChangeLog README*
+
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # (Dec 12 2003 solar@gentoo) Bug #35623
+ # fix malformed dcc send bug.
+ # discovered by lloydbates Martin Wienold of University of Dortmund - Germany in #gentoo/#gentoo.de
+ # orig patch credits go to jcdutton
+ # secondary patch credits go to rac@gentoo which process the malformed dcc requests accordingly.
+ epatch ${FILESDIR}/${PN}-2.0.6-fix_dccsend.patch
+}