summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-04 15:00:56 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-04 15:00:56 +0000
commitecd01760e7ec92fd244d230b4589784190580ec0 (patch)
treecff3c03935d32eaacaf83db102e4ad67b4b31a55 /net-irc
parentfixed deps (diff)
downloadhistorical-ecd01760e7ec92fd244d230b4589784190580ec0.tar.gz
historical-ecd01760e7ec92fd244d230b4589784190580ec0.tar.bz2
historical-ecd01760e7ec92fd244d230b4589784190580ec0.zip
*pop* there it is again
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog5
-rw-r--r--net-irc/xchat/files/digest-xchat-1.9.61
-rw-r--r--net-irc/xchat/xchat-1.9.6.ebuild95
3 files changed, 100 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 91e00400e6ed..2d0a7934b725 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.31 2002/11/26 12:08:32 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.32 2002/12/04 15:00:56 foser Exp $
*xchat-1.9.6 (26 Nov 2002)
+ 04 Dec 2002; foser <foser@gentoo.org> xchat-1.9.6.ebuild :
+ Readded, disabled the segfaulting japanese conv support
+
26 Nov 2002; foser <foser@gentoo.org> xchat-1.9.6.ebuild :
New version
diff --git a/net-irc/xchat/files/digest-xchat-1.9.6 b/net-irc/xchat/files/digest-xchat-1.9.6
new file mode 100644
index 000000000000..e4a3ea4658ac
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.9.6
@@ -0,0 +1 @@
+MD5 dc81d4440ac3dac3b30129f0b28c1433 xchat-1.9.6.tar.bz2 821649
diff --git a/net-irc/xchat/xchat-1.9.6.ebuild b/net-irc/xchat/xchat-1.9.6.ebuild
new file mode 100644
index 000000000000..ea5144a7ef74
--- /dev/null
+++ b/net-irc/xchat/xchat-1.9.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.9.6.ebuild,v 1.3 2002/12/04 15:00:56 foser Exp $
+
+inherit eutils
+
+IUSE="perl gnome ssl gtk python mmx ipv6 nls kde"
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86 ~ppc ~sparc ~sparc64"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=x11-libs/libzvt-2.0.1
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/gnome-applets-2.0.0
+ >=gnome-base/gnome-panel-2.0.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+# From the xchat 1.9.3 README_FIRST file:
+# (one of the) REMAINING PROBLEMS:
+# * can't compile with gnome, panel and zvt support *
+# stroke
+
+src_compile() {
+
+ local myopts myflags
+
+ if [ ! `use perl` ] ; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ || myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use python \
+ || myopts="${myopts} --disable-python"
+
+ use nls \
+ && myopts="${myopts} --enable-nls --enable-hebrew" \
+ || myopts="${myopts} --disable-nls --disable-hebrew"
+ # --enable-japanese-conv is broken in xchat-1.9.6
+
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+
+ [ -n "${DISABLE_XFT}" ] && myopts="${myopts} --disable-xft"
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ dodoc AUTHORS COPYING ChangeLog README
+}
+
+pkg_postinst() {
+ einfo "If you want X-Chat to correctly display Hebrew (bidi) do "
+ einfo "'export DISABLE_XFT=1' and re-emerge xchat"
+}