summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-12-18 14:35:28 +0000
committerEray Aslan <eras@gentoo.org>2011-12-18 14:35:28 +0000
commit0316b9fd1257c599af44859d19843edd31c80f76 (patch)
treeb7acc3a11eb4a1793d711d148d48c61945db9a36 /net-libs/liblockfile/liblockfile-1.09.ebuild
parentRemove old versions. (diff)
downloadhistorical-0316b9fd1257c599af44859d19843edd31c80f76.tar.gz
historical-0316b9fd1257c599af44859d19843edd31c80f76.tar.bz2
historical-0316b9fd1257c599af44859d19843edd31c80f76.zip
version bump and remove old patches
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'net-libs/liblockfile/liblockfile-1.09.ebuild')
-rw-r--r--net-libs/liblockfile/liblockfile-1.09.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/liblockfile/liblockfile-1.09.ebuild b/net-libs/liblockfile/liblockfile-1.09.ebuild
new file mode 100644
index 000000000000..d1d095be9139
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.09.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.09.ebuild,v 1.1 2011/12/18 14:35:28 eras Exp $
+
+EAPI=4
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+pkg_setup() {
+ enewgroup mail 12
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.06-respectflags.patch
+ epatch "${FILESDIR}"/${PN}-orphan-file.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-mailgroup=mail --enable-shared
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ emake ROOT="${ED}" install
+ dodoc README Changelog
+}