summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-06-09 20:31:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-06-09 20:31:45 +0000
commit9506828200c7b0ae5155edb0f4c7c0a5ad01abf2 (patch)
treeabe345370b33844f6be19e95a798950a7e964d85 /net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild
parentFix prefix and multilibness. (diff)
downloadhistorical-9506828200c7b0ae5155edb0f4c7c0a5ad01abf2.tar.gz
historical-9506828200c7b0ae5155edb0f4c7c0a5ad01abf2.tar.bz2
historical-9506828200c7b0ae5155edb0f4c7c0a5ad01abf2.zip
Fixed unaligned access on platforms not supporting one (http://libtorrent.rakshasa.no/ticket/1263).
Package-Manager: portage-2.1.9.50/cvs/Linux x86_64
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild b/net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild
new file mode 100644
index 000000000000..03e44a77f904
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.7-r1.ebuild,v 1.1 2011/06/09 20:31:45 slyfox Exp $
+
+EAPI=2
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.12.6-gcc44.patch
+ epatch "${FILESDIR}"/${P}-test.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.6.0.patch
+ epatch "${FILESDIR}"/download_constructor.diff
+ epatch "${FILESDIR}"/${P}-DHT-unaligned-access.patch
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}