summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-21 17:25:39 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-21 17:25:39 +0000
commit0ae3af3aa2b97150f93c04a364360e9e9c3097a9 (patch)
treeefe7dde335728428f2aef39e1fc67553bdc6d4aa /net-libs/wvstreams
parentAdded metadata.xml (diff)
downloadhistorical-0ae3af3aa2b97150f93c04a364360e9e9c3097a9.tar.gz
historical-0ae3af3aa2b97150f93c04a364360e9e9c3097a9.tar.bz2
historical-0ae3af3aa2b97150f93c04a364360e9e9c3097a9.zip
Fixed gcc-3.4 compile issues and broken header in 3.74 ebuild
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog8
-rw-r--r--net-libs/wvstreams/Manifest7
-rw-r--r--net-libs/wvstreams/files/wvstreams-3.75-gcc34.patch86
-rw-r--r--net-libs/wvstreams/wvstreams-3.74.ebuild1
-rw-r--r--net-libs/wvstreams/wvstreams-3.75.ebuild5
5 files changed, 102 insertions, 5 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index d4a8ebb21811..ecf7b16b7c61 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.20 2004/08/12 22:39:30 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.21 2004/09/21 17:25:39 sekretarz Exp $
+
+ 21 Sep 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/wvstreams-3.75-gcc34.patch, wvstreams-3.74.ebuild,
+ wvstreams-3.75.ebuild:
+ Fixed gcc-3.4 compile issues. Thanks to Chris Arepantis
+ <ChrisArepantis@gmail.com> in bug #62822. Fixed broken header in 3.74 ebuild
*wvstreams-3.75-r1 (12 Aug 2004)
diff --git a/net-libs/wvstreams/Manifest b/net-libs/wvstreams/Manifest
index 866dec4e5076..998402b11243 100644
--- a/net-libs/wvstreams/Manifest
+++ b/net-libs/wvstreams/Manifest
@@ -1,7 +1,7 @@
MD5 84906df12ff06c74e269a55f292f09ac wvstreams-3.70-r2.ebuild 869
-MD5 4b05161eef8aad115e98cd02a78cb01a wvstreams-3.75.ebuild 1811
-MD5 1df223cd3261533626bd3efc2d4bcd4a wvstreams-3.74.ebuild 1274
-MD5 97a7b94bca87ce7b4c6cd8ef61fc6f68 ChangeLog 2889
+MD5 0862b8114d16323fe2a50f81b4496289 wvstreams-3.75.ebuild 1868
+MD5 d991640e2ff373e482b3c3478282fef1 wvstreams-3.74.ebuild 1392
+MD5 636fc0fd686ac1c5ca3ec499b8b8cd63 ChangeLog 3171
MD5 dab468062cf36e0e81e72fb2a59299e0 files/3.70-gcc3.patch 3171
MD5 5d649f23e7b31fb9224bace4c35bcf3e files/3.70-openssl.patch 470
MD5 0ee90e98345afff96aaf89dbda1910fc files/digest-wvstreams-3.74 68
@@ -13,3 +13,4 @@ MD5 c48022170e1e20f8222af4b4711373eb files/wvstreams-3.74-makefile.patch 363
MD5 f2058097f693e07dadf248b1a3319db3 files/digest-wvstreams-3.70-r2 66
MD5 b8b38bbbccf83a9024a243149fd9b7d1 files/wvstreams-3.70-gentoo.patch 1174
MD5 7a2a3fb9116991ebccad327a9ad0fd87 files/wvstreams-3.75-tcl_8_4.patch 945
+MD5 e4f46fcdd724dc1c316aefe9e0228dac files/wvstreams-3.75-gcc34.patch 3573
diff --git a/net-libs/wvstreams/files/wvstreams-3.75-gcc34.patch b/net-libs/wvstreams/files/wvstreams-3.75-gcc34.patch
new file mode 100644
index 000000000000..0961fd84afee
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-3.75-gcc34.patch
@@ -0,0 +1,86 @@
+diff -aur wvstreams-3.75.0/include/uniconftree.h /tmp/wvstreams-3.75.0/include/uniconftree.h
+--- wvstreams-3.75.0/include/uniconftree.h 2004-03-13 20:59:36.000000000 +0200
++++ /tmp/wvstreams-3.75.0/include/uniconftree.h 2004-09-04 16:43:30.393037423 +0300
+@@ -48,7 +48,7 @@
+
+ /** Returns a pointer to the parent node, or NULL if there is none. */
+ Sub *parent() const
+- { return static_cast<Sub*>(xparent); }
++ { return static_cast <Sub*>(this->xparent); }
+
+ /** Reparents this node. */
+ void setparent(Sub *parent)
+@@ -56,7 +56,7 @@
+
+ /** Returns a pointer to the root node of the tree. */
+ Sub *root() const
+- { return static_cast<Sub*>(Base::_root()); }
++ { return static_cast <Sub*>(Base::_root()); }
+
+ /**
+ * Returns full path of this node relative to an ancestor.
+@@ -93,13 +93,13 @@
+ /** Removes and deletes all children of this node. */
+ void zap()
+ {
+- if (!xchildren)
++ if (!(this->xchildren))
+ return;
+ // set xchildren to NULL first so that the zap() will happen faster
+ // otherwise, each child will attempt to unlink itself uselessly
+
+- typename Base::Container *oldchildren = xchildren;
+- xchildren = NULL;
++ typename Base::Container *oldchildren = this->xchildren;
++ this->xchildren = NULL;
+
+ // delete all children
+ typename Base::Container::Iter i(*oldchildren);
+diff -aur wvstreams-3.75.0/include/wvscatterhash.h /tmp/wvstreams-3.75.0/include/wvscatterhash.h
+--- wvstreams-3.75.0/include/wvscatterhash.h 2004-03-13 20:59:36.000000000 +0200
++++ /tmp/wvstreams-3.75.0/include/wvscatterhash.h 2004-09-04 16:25:34.378896875 +0300
+@@ -154,7 +154,7 @@
+ { _set_autofree(Accessor::get_key(data), hash(data), auto_free); }
+
+ bool get_autofree(const T *data)
+- { _get_autofree(Accessor::get_key(data), hash(data)); }
++ { return _get_autofree(Accessor::get_key(data), hash(data)); }
+
+ void zap()
+ { _zap(); }
+diff -aur wvstreams-3.75.0/include/wvsorter.h /tmp/wvstreams-3.75.0/include/wvsorter.h
+--- wvstreams-3.75.0/include/wvsorter.h 2004-03-13 20:59:36.000000000 +0200
++++ /tmp/wvstreams-3.75.0/include/wvsorter.h 2004-09-04 16:26:41.699819665 +0300
+@@ -90,7 +90,7 @@
+ for (i.rewind(); i.next(); )
+ n++;
+
+- array = new (void *) [n+2];
++ array = new void * [n+2];
+ void **aptr = array;
+
+ *aptr++ = NULL; // initial link is NULL, to act like a normal iterator
+diff -aur wvstreams-3.75.0/utils/wvbuffer.cc /tmp/wvstreams-3.75.0/utils/wvbuffer.cc
+--- wvstreams-3.75.0/utils/wvbuffer.cc 2004-03-13 20:59:36.000000000 +0200
++++ /tmp/wvstreams-3.75.0/utils/wvbuffer.cc 2004-09-04 16:28:40.100538512 +0300
+@@ -9,13 +9,13 @@
+ /***** Specialization for raw memory buffers *****/
+
+ // Instantiate some commonly used templates
+-template WvBufBaseCommonImpl<unsigned char>;
+-template WvInPlaceBufBase<unsigned char>;
+-template WvConstInPlaceBufBase<unsigned char>;
+-template WvCircularBufBase<unsigned char>;
+-template WvDynBufBase<unsigned char>;
+-template WvNullBufBase<unsigned char>;
+-template WvBufCursorBase<unsigned char>;
++template class WvBufBaseCommonImpl<unsigned char>;
++template class WvInPlaceBufBase<unsigned char>;
++template class WvConstInPlaceBufBase<unsigned char>;
++template class WvCircularBufBase<unsigned char>;
++template class WvDynBufBase<unsigned char>;
++template class WvNullBufBase<unsigned char>;
++template class WvBufCursorBase<unsigned char>;
+
+ void WvBufBase<unsigned char>::putstr(WvStringParm str)
+ {
diff --git a/net-libs/wvstreams/wvstreams-3.74.ebuild b/net-libs/wvstreams/wvstreams-3.74.ebuild
index 1426f91a3b20..076645069f13 100644
--- a/net-libs/wvstreams/wvstreams-3.74.ebuild
+++ b/net-libs/wvstreams/wvstreams-3.74.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.74.ebuild,v 1.8 2004/09/21 17:25:39 sekretarz Exp $
inherit eutils
diff --git a/net-libs/wvstreams/wvstreams-3.75.ebuild b/net-libs/wvstreams/wvstreams-3.75.ebuild
index 5494913e62c5..b54dace696c5 100644
--- a/net-libs/wvstreams/wvstreams-3.75.ebuild
+++ b/net-libs/wvstreams/wvstreams-3.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.75.ebuild,v 1.8 2004/08/12 22:39:30 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.75.ebuild,v 1.9 2004/09/21 17:25:39 sekretarz Exp $
inherit eutils
@@ -48,6 +48,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-makefile.patch
epatch ${FILESDIR}/${P}-fPIC.patch
+ #gcc-3.4 fix
+ epatch ${FILESDIR}/${P}-gcc34.patch
+
if has_version =dev-lang/tcl-8.4*; then
epatch ${FILESDIR}/${P}-tcl_8_4.patch
autoconf || die