summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-16 23:01:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-16 23:01:54 +0000
commit13c3029ab268c9b41423a74d6d48d14c02525374 (patch)
tree6d614241bbb3361afb48659c8998b1cbeb465643 /net-libs
parentAdded ~ppc to keywords (diff)
downloadhistorical-13c3029ab268c9b41423a74d6d48d14c02525374.tar.gz
historical-13c3029ab268c9b41423a74d6d48d14c02525374.tar.bz2
historical-13c3029ab268c9b41423a74d6d48d14c02525374.zip
better SLOT
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnet/ChangeLog22
-rw-r--r--net-libs/libnet/files/digest-libnet-1.1.0-r2 (renamed from net-libs/libnet/files/digest-libnet-1.1.0-r1)0
-rw-r--r--net-libs/libnet/libnet-1.1.0-r2.ebuild (renamed from net-libs/libnet/libnet-1.1.0-r1.ebuild)38
3 files changed, 33 insertions, 27 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index 9f6831ae3f4d..83a41475d939 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,18 +1,18 @@
# ChangeLog for net-libs/libnet
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.16 2003/07/24 16:39:02 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.17 2003/08/16 23:01:32 vapier Exp $
- 24 Jul 2003; Hanno Boeck <hanno@gentoo.org> libnet-1.0.2a-r2.ebuild,
- files/libnet-gcc33-fix:
- Compile fix for gcc 3.3.
-
- 21 May 2003; Tavis Ormandy <taviso@gentoo.org> libnet-1.1.0-r1.ebuild:
- arking stable on alpha.
+*libnet-1.1.0-r2 (16 Aug 2003)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+ 16 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Rather than using ${PV} for file tagging, use ${SLOT} ...
+ Also, move library to /usr/lib/libnet${SLOT}.a
*libnet-1.1.0-r1 (02 Oct 2002)
+ 21 May 2003; Tavis Ormandy <taviso@gentoo.org> libnet-1.1.0-r1.ebuild:
+ arking stable on alpha.
+
22 Apr 2003; Brandon Low <lostlogic@gentoo.org> libnet-1.1.0-r1.ebuild:
Change supersed dependencies
@@ -21,6 +21,12 @@
*libnet-1.0.2a-r2 (02 Oct 2002)
+ 24 Jul 2003; Hanno Boeck <hanno@gentoo.org> libnet-1.0.2a-r2.ebuild,
+ files/libnet-gcc33-fix:
+ Compile fix for gcc 3.3.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
28 Apr 2003; Zach Welch <zwelch@gentoo.org> libnet-1.0.2a-r2.ebuild:
add arm keyword
diff --git a/net-libs/libnet/files/digest-libnet-1.1.0-r1 b/net-libs/libnet/files/digest-libnet-1.1.0-r2
index bdfe61b76eae..bdfe61b76eae 100644
--- a/net-libs/libnet/files/digest-libnet-1.1.0-r1
+++ b/net-libs/libnet/files/digest-libnet-1.1.0-r2
diff --git a/net-libs/libnet/libnet-1.1.0-r1.ebuild b/net-libs/libnet/libnet-1.1.0-r2.ebuild
index a3b8e562d688..e7514ecf89f0 100644
--- a/net-libs/libnet/libnet-1.1.0-r1.ebuild
+++ b/net-libs/libnet/libnet-1.1.0-r2.ebuild
@@ -1,45 +1,45 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.0-r1.ebuild,v 1.6 2003/05/21 15:44:04 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.0-r2.ebuild,v 1.1 2003/08/16 23:01:32 vapier Exp $
-S=${WORKDIR}/Libnet-latest
-DESCRIPTION="library to provide an API for commonly used low-level network
-functions (mainly packet injection). Used by packet scrubbers and the like,
-not to be confused with the perl libnet"
-SRC_URI="http://www.packetfactory.net/${PN}/dist/${P}.tar.gz"
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
HOMEPAGE="http://www.packetfactory.net/libnet/"
+SRC_URI="http://www.packetfactory.net/${PN}/dist/${P}.tar.gz"
-DEPEND="=sys-apps/sed-4*"
-
-SLOT="1.1"
LICENSE="LGPL-2"
+SLOT="1.1"
KEYWORDS="x86 alpha"
+DEPEND="=sys-apps/sed-4*"
+
+S=${WORKDIR}/Libnet-latest
+
src_compile(){
econf \
- --libdir=/usr/lib/libnet-${PV} \
- --includedir=/usr/include/libnet-${PV} \
- --program-suffix=-${PV} \
+ --libdir=/usr/lib/libnet-${SLOT} \
+ --includedir=/usr/include/libnet-${SLOT} \
+ --program-suffix=-${SLOT} \
|| die
-
emake || die "Failed to compile"
}
src_install(){
make DESTDIR=${D} install || die "Failed to install"
- sed -i "s/libnet-config/&-${PV}/" libnet-config
- exeinto /usr/bin
- newexe libnet-config libnet-config-${PV}
-
dodoc VERSION README doc/*
docinto Ancillary ; dodoc doc/Ancillary/README*
docinto sample ; dodoc sample/*.[ch]
+
+ sed -i "s/libnet-config/&-${SLOT}/" libnet-config
+ newbin libnet-config libnet-config-${SLOT}
+ cd ${D}/usr/lib
+ mv libnet-${SLOT}/libnet.a libnet${SLOT}.a
+ rm -rf libnet-${SLOT}
}
pkg_postinst(){
echo
- einfo "config script for libnet version ${PV} is libnet-config-${PV}"
- einfo "manpage for libnet version ${PV} is libnet-${PV}"
+ einfo "config script for libnet version ${SLOT} is libnet-config-${SLOT}"
+ einfo "manpage for libnet version ${SLOT} is libnet-${SLOT}"
echo
}