summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-05 07:15:07 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-05 07:15:07 +0000
commit34afd5274697076a5be42ec3afeb8e04670a89d0 (patch)
tree3b573668946d059976f766e3b21c52a3dab9352d /net-libs
parentAdded sparc note. (diff)
downloadhistorical-34afd5274697076a5be42ec3afeb8e04670a89d0.tar.gz
historical-34afd5274697076a5be42ec3afeb8e04670a89d0.tar.bz2
historical-34afd5274697076a5be42ec3afeb8e04670a89d0.zip
Do compilation in ebuild rather than use upstream Makefile...
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libhttpd-persistent/ChangeLog4
-rw-r--r--net-libs/libhttpd-persistent/Manifest4
-rw-r--r--net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild25
3 files changed, 17 insertions, 16 deletions
diff --git a/net-libs/libhttpd-persistent/ChangeLog b/net-libs/libhttpd-persistent/ChangeLog
index cf8a06e72e56..fe1d9babeb2e 100644
--- a/net-libs/libhttpd-persistent/ChangeLog
+++ b/net-libs/libhttpd-persistent/ChangeLog
@@ -1,10 +1,10 @@
# ChangeLog for net-libs/libhttpd-persistent
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/ChangeLog,v 1.7 2004/07/05 06:30:58 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/ChangeLog,v 1.8 2004/07/05 07:15:07 eradicator Exp $
04 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
libhttpd-persistent-1.3p-r6.ebuild:
- Added .o files to linking...
+ just discard borked upstream Makefile and do it in ebuild...
05 Jul 2004; Danny van Dyk <kugelfang@gentoo.org>
libhttpd-persistent-1.3p-r6.ebuild:
diff --git a/net-libs/libhttpd-persistent/Manifest b/net-libs/libhttpd-persistent/Manifest
index 3893ece02d0b..a926d141c8e2 100644
--- a/net-libs/libhttpd-persistent/Manifest
+++ b/net-libs/libhttpd-persistent/Manifest
@@ -1,4 +1,4 @@
-MD5 26f811bd6ecdaf0dc338405f90a953ca ChangeLog 1964
-MD5 3ae81b30ef53beae469a8cda39c37965 libhttpd-persistent-1.3p-r6.ebuild 1426
+MD5 6cf13053c2b165c1b5bf55de46c614fb ChangeLog 1996
+MD5 4549c381890e5ec90b78241bcbaa4d36 libhttpd-persistent-1.3p-r6.ebuild 1424
MD5 34371b0b6264e8222d4666bf5895f5f7 metadata.xml 432
MD5 3d54fde5d128291ea5a6ae6dd4f9d840 files/digest-libhttpd-persistent-1.3p-r6 64
diff --git a/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild b/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild
index 1471223058ae..8685dfb84e9c 100644
--- a/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild
+++ b/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild,v 1.7 2004/07/05 06:30:58 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild,v 1.8 2004/07/05 07:15:07 eradicator Exp $
MY_P="libhttpd-1.3p-f"
@@ -18,22 +18,23 @@ S="${WORKDIR}/libhttpd-1.3-persistent-f"
src_compile() {
econf || die
- # This is for versions since libhttpd-1.3p-e until the configure
- # process properly detects g++
- sed -i 's:gcc:g++:' Site.mm
- # end gcc to g++ edits.
+ # Package provided compilation is FUBAR
+ cd ${S}/src
- emake || die
+ CFILES="protocol.c api.c version.c ip_acl.c select.c"
+ OFILES=${CFILES//.c/.o}
- cd ${S}/src
+ for FILE in ${CFILES}; do
+ echo g++ ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE}
+ g++ ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE} || die
+ done
+
+ echo "linking"
+ ar rc libhttpd-persistent.a ${OFILES} || die
ranlib libhttpd-persistent.a || die
- for FILE in "protocol.c api.c version.c ip_acl.c select.c"; do
- g++ ${CFLAGS} -D_OS_UNIX -fPIC -c ${FILE}
- done
g++ -shared -Wl,-shared,-soname,libhttpd-persistent.so \
- protocol.o api.o version.o ip_acl.o select.o \
- -o libhttpd-persistent.so || die
+ ${OFILES} -o libhttpd-persistent.so || die
}
src_install() {