summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-09-08 22:12:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-09-08 22:12:26 +0000
commit94f1f114c6a3812c8350db8c22230bdf9efa37a3 (patch)
tree04bf19e303ad7c3e14d0a8e656fbafb0388389eb /net-libs
parentInitial ebuild. (diff)
downloadhistorical-94f1f114c6a3812c8350db8c22230bdf9efa37a3.tar.gz
historical-94f1f114c6a3812c8350db8c22230bdf9efa37a3.tar.bz2
historical-94f1f114c6a3812c8350db8c22230bdf9efa37a3.zip
Version bump.
Package-Manager: portage-2.2.0_alpha54/cvs/Linux x86_64
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp-av/ChangeLog7
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.10.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/gupnp-av/ChangeLog b/net-libs/gupnp-av/ChangeLog
index 739b379f702d..568ba17d8608 100644
--- a/net-libs/gupnp-av/ChangeLog
+++ b/net-libs/gupnp-av/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-av
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.14 2011/08/14 10:20:59 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.15 2011/09/08 22:12:26 eva Exp $
+
+*gupnp-av-0.10.1 (08 Sep 2011)
+
+ 08 Sep 2011; Gilles Dartiguelongue <eva@gentoo.org> +gupnp-av-0.10.1.ebuild:
+ Version bump.
14 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -gupnp-av-0.4.1.ebuild,
-gupnp-av-0.5.2.ebuild, -gupnp-av-0.5.7.ebuild, -gupnp-av-0.6.1.ebuild,
diff --git a/net-libs/gupnp-av/gupnp-av-0.10.1.ebuild b/net-libs/gupnp-av/gupnp-av-0.10.1.ebuild
new file mode 100644
index 000000000000..636258a2cfc1
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.10.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/gupnp-av-0.10.1.ebuild,v 1.1 2011/09/08 22:12:26 eva Exp $
+
+EAPI="4"
+
+inherit gnome.org
+
+DESCRIPTION="A small utility library that aims to ease the handling UPnP A/V profiles"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ >=net-libs/gupnp-0.17[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-static \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf
+}
+
+src_install() {
+ default
+ # Remove pointless .la files
+ find "${D}" -name '*.la' -delete
+}