summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-11-02 19:02:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-11-02 19:02:35 +0000
commitf19dd785c6815aa4aaa8d768b362623bc7cfa5a1 (patch)
treee36f4e088a65be3cea9ac7856f375136a079ef29 /net-mail/altermime/altermime-0.3.10-r1.ebuild
parentRemove voxus from metadata.xml (diff)
downloadhistorical-f19dd785c6815aa4aaa8d768b362623bc7cfa5a1.tar.gz
historical-f19dd785c6815aa4aaa8d768b362623bc7cfa5a1.tar.bz2
historical-f19dd785c6815aa4aaa8d768b362623bc7cfa5a1.zip
Fixes for #241038, thanks to Kerin Millar
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64
Diffstat (limited to 'net-mail/altermime/altermime-0.3.10-r1.ebuild')
-rw-r--r--net-mail/altermime/altermime-0.3.10-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-mail/altermime/altermime-0.3.10-r1.ebuild b/net-mail/altermime/altermime-0.3.10-r1.ebuild
new file mode 100644
index 000000000000..a3512ac3ae32
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/altermime-0.3.10-r1.ebuild,v 1.1 2010/11/02 19:02:35 patrick Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fprintf-fixes.patch \
+ "${FILESDIR}"/${P}-MIME_headers-overflow.patch \
+ "${FILESDIR}"/${P}-respect-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ dobin altermime || die
+ dodoc CHANGELOG README || die
+}