summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-28 17:22:44 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-28 17:22:44 +0000
commitd0d98c1aaefb94c1c35f9608276af98a8982adb0 (patch)
tree54a8ab8f4a1faae531664be60f32a8c993a812d4 /net-mail/vlnx
parentUnmasked unarj (diff)
downloadhistorical-d0d98c1aaefb94c1c35f9608276af98a8982adb0.tar.gz
historical-d0d98c1aaefb94c1c35f9608276af98a8982adb0.tar.bz2
historical-d0d98c1aaefb94c1c35f9608276af98a8982adb0.zip
Added nostrip options and changed install directory. Fixes #6913.
Diffstat (limited to 'net-mail/vlnx')
-rw-r--r--net-mail/vlnx/ChangeLog9
-rw-r--r--net-mail/vlnx/files/vlnx-414e-envd2
-rw-r--r--net-mail/vlnx/vlnx-414e-r2.ebuild18
3 files changed, 19 insertions, 10 deletions
diff --git a/net-mail/vlnx/ChangeLog b/net-mail/vlnx/ChangeLog
index 1c7dec0c7152..e8b52923208c 100644
--- a/net-mail/vlnx/ChangeLog
+++ b/net-mail/vlnx/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for net-mail/vlnx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vlnx/ChangeLog,v 1.2 2002/03/19 05:10:18 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vlnx/ChangeLog,v 1.3 2002/08/28 17:22:44 rphillips Exp $
*vlnx-414e-r1 (1 Feb 2002)
+
+ 28 Aug 2002; Ryan Phillips <rphillips@gentoo.org> :
+
+ Changed install directory to /opt.
+ Added an env.d/ file to update the path.
+ Added a nostrip option so it doesn't mess with the executables.
+
18 Mar 2002; Chad Huneycutt <chadh@gentoo.org>
uvscan was complaining of missing library, which indeed was not being
installed. I updated the ebuild to install the library and also a man page.
diff --git a/net-mail/vlnx/files/vlnx-414e-envd b/net-mail/vlnx/files/vlnx-414e-envd
new file mode 100644
index 000000000000..71af712dedeb
--- /dev/null
+++ b/net-mail/vlnx/files/vlnx-414e-envd
@@ -0,0 +1,2 @@
+PATH=/opt/vlnx
+LD_LIBRARY_PATH=/opt/vlnx
diff --git a/net-mail/vlnx/vlnx-414e-r2.ebuild b/net-mail/vlnx/vlnx-414e-r2.ebuild
index 4e1442c54c5e..529f333f9c03 100644
--- a/net-mail/vlnx/vlnx-414e-r2.ebuild
+++ b/net-mail/vlnx/vlnx-414e-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Script Revised by Parag Mehta <pm@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vlnx/vlnx-414e-r2.ebuild,v 1.5 2002/08/14 12:05:25 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vlnx/vlnx-414e-r2.ebuild,v 1.6 2002/08/28 17:22:44 rphillips Exp $
MY_P=${PN}${PV}
@@ -13,9 +13,10 @@ SRC_URI="http://download.mcafee.com/products/evaluation/virusscan/english/unix/l
SLOT="0"
LICENSE="VirusScan"
KEYWORDS="x86 sparc sparc64"
-
+RESTRICT="nostrip"
DEPEND=""
RDEPEND="sys-devel/ld.so"
+
src_unpack() {
cd ${WORKDIR}
mkdir ${MY_P}
@@ -26,16 +27,15 @@ src_unpack() {
src_install() {
dodir /usr/bin
- insinto /usr/lib
- insopts -m 555
+ insinto /opt/vlnx
+
doins liblnxfv.so
- insinto /usr/share/vscan
- insopts -m 755
doins uvscan
- insopts -m 444
doins *.dat
dodoc *.txt *.pdf
-
- dosym /usr/share/vscan/uvscan /usr/bin/uvscan
doman uvscan.1
+ chmod 755 ${D}/opt/vlnx/uvscan
+
+ mkdir -p ${D}/etc/env.d
+ cp -f ${FILESDIR}/vlnx-${PV}-envd ${D}/etc/env.d/40vlnx
}