summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-18 04:10:07 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-18 04:10:07 +0000
commit5eca50db11fef56021509a946833dd2e27fb6e5a (patch)
tree21cf8f43307dd1eb0acc8af8fba6c9e5a489e4ad /net-mail
parentVersion bump and added kerberos and krb4 support. (diff)
downloadhistorical-5eca50db11fef56021509a946833dd2e27fb6e5a.tar.gz
historical-5eca50db11fef56021509a946833dd2e27fb6e5a.tar.bz2
historical-5eca50db11fef56021509a946833dd2e27fb6e5a.zip
Version bump and added kerberos and krb4 support.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest4
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.4.ebuild88
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.41
3 files changed, 91 insertions, 2 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 6aea9c567341..580ab3918f90 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,9 +1,9 @@
MD5 64bf477646087eebe46e8acd9e3c3dac fetchmail-6.2.1-r1.ebuild 1789
-MD5 7da3bc24ec9cc013bf8ad8e21eefcf3b fetchmail-6.2.4.ebuild 2188
+MD5 ac8fddd63f6c6c3ade424e88d7e1b6a5 fetchmail-6.2.4.ebuild 2156
MD5 d7a2a5454208f393dcfbf0c9ebad98c9 fetchmail-5.9.14.ebuild 1941
MD5 71e6bdc8a05311118f8c32cdecf2e64a fetchmail-6.2.2-r2.ebuild 2053
MD5 26cb42b7561ecc18c8a3b3f580bf19b8 fetchmail-6.2.3.ebuild 1972
-MD5 c651ace7d3730a8a96e91352297b16a0 ChangeLog 5627
+MD5 6af5204432b41b0d4d3171b79df4f106 ChangeLog 5784
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 5b0a50b0a0193afbcb7eff9ac3d5fcb7 files/digest-fetchmail-6.2.1-r1 68
MD5 72af1b79f1e6aab29edbdefdcce8c1c7 files/digest-fetchmail-6.2.2-r2 68
diff --git a/net-mail/fetchmail/fetchmail-6.2.4.ebuild b/net-mail/fetchmail/fetchmail-6.2.4.ebuild
new file mode 100644
index 000000000000..8e1aa8fbcc52
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.4.ebuild,v 1.1 2003/08/18 04:10:02 g2boojum Exp $
+
+IUSE="ssl nls ipv6 kerberos krb4"
+
+inherit eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.catb.org/~esr/fetchmail/"
+SRC_URI="http://www.catb.org/~esr/fetchmail/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86 ~alpha"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fetchmail-6.2.0-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl"
+ use nls || myconf="${myconf} --disable-nls"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use kerberos && myconf="${myconf} --with-gssapi --with-kerberos5"
+ use krb4 && myconf="${myconf} --with-kerberos"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.4 b/net-mail/fetchmail/files/digest-fetchmail-6.2.4
new file mode 100644
index 000000000000..61cc41599e08
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.4
@@ -0,0 +1 @@
+MD5 3614acbda936548d2f8d5bffb161ff59 fetchmail-6.2.4.tar.gz 1247210