summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-26 06:06:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-26 06:06:22 +0000
commiteedb1ed807cfbe150e015bee8e2fa714e1ece43a (patch)
tree3a8c49e434cd699440894804863c596482873cc0 /net-mail
parentbump to x86 and install more manpages (diff)
downloadhistorical-eedb1ed807cfbe150e015bee8e2fa714e1ece43a.tar.gz
historical-eedb1ed807cfbe150e015bee8e2fa714e1ece43a.tar.bz2
historical-eedb1ed807cfbe150e015bee8e2fa714e1ece43a.zip
bump to x86 and install more manpages
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/uw-imap/Manifest6
-rw-r--r--net-mail/uw-imap/files/digest-uw-imap-2002e-r11
-rw-r--r--net-mail/uw-imap/uw-imap-2002e-r1.ebuild116
-rw-r--r--net-mail/uw-imap/uw-imap-2002e.ebuild4
4 files changed, 122 insertions, 5 deletions
diff --git a/net-mail/uw-imap/Manifest b/net-mail/uw-imap/Manifest
index 8ee0af006bb5..02a064a0aee1 100644
--- a/net-mail/uw-imap/Manifest
+++ b/net-mail/uw-imap/Manifest
@@ -1,7 +1,7 @@
-MD5 14746f452e85e20ca3689ad03a28e3d6 uw-imap-2002e.ebuild 2923
-MD5 1bd02a81fe78546d1b826c97cf661c3d uw-imap-2002e-r1.ebuild 2990
+MD5 611fce309de65e46833fb25915edfee6 uw-imap-2002e.ebuild 2923
+MD5 0b5262f34e299a26e88c82ecba038c05 uw-imap-2002e-r1.ebuild 2993
MD5 23805974cdbe25a1bc2b5035a0fa1470 uw-imap-2002d-r1.ebuild 2927
-MD5 c1e40be670506fdab59753f150330bab ChangeLog 4272
+MD5 aab334451656b5a27a698222b32bb6f5 ChangeLog 4272
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 f953db17eebd14c338b07bf5b46645b4 uw-imap-2002d.ebuild 2577
MD5 506e7347cac698714cf5cd60eca761ba files/uw-ipop2.xinetd 563
diff --git a/net-mail/uw-imap/files/digest-uw-imap-2002e-r1 b/net-mail/uw-imap/files/digest-uw-imap-2002e-r1
new file mode 100644
index 000000000000..cbbff9d87969
--- /dev/null
+++ b/net-mail/uw-imap/files/digest-uw-imap-2002e-r1
@@ -0,0 +1 @@
+MD5 0d246d868f20d8c441d235b77c940676 imap-2002e.tar.Z 2157511
diff --git a/net-mail/uw-imap/uw-imap-2002e-r1.ebuild b/net-mail/uw-imap/uw-imap-2002e-r1.ebuild
new file mode 100644
index 000000000000..0a51693af75b
--- /dev/null
+++ b/net-mail/uw-imap/uw-imap-2002e-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2002e-r1.ebuild,v 1.1 2003/10/26 06:05:30 robbat2 Exp $
+
+MY_P=imap-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW server daemons for IMAP and POP network mail protocols."
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc ~hppa ~alpha"
+IUSE="ssl mbox pic"
+
+PROVIDE="virtual/imapd"
+PROVIDE="${PROVIDE} virtual/imap-c-client"
+DEPEND="!net-mail/vimap
+ !virtual/imap-c-client
+ virtual/glibc
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ use pic || use alpha && append-flags -fPIC
+
+ cd ${S}/src/osdep/unix/
+ cp Makefile Makefile.orig
+ sed \
+ -e 's,-g -fno-omit-frame-pointer -O6,${CFLAGS},g' \
+ -e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
+ -e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
+ < Makefile.orig > Makefile
+
+ # Uncomment this for MBX support
+ #cp Makefile Makefile.orig2
+ #sed \
+ # -e "s:CREATEPROTO=unixproto:CREATEPROTO=mbxproto:" \
+ # -e "s:EMPTYPROTO=unixproto:EMPTYPROTO=mbxproto:" \
+ # < Makefile.orig2 > Makefile
+ cd ${S}
+}
+
+src_compile() {
+ if use ssl; then
+ cd ${S}
+ yes | make lnp SSLTYPE=unix || die
+
+ local i
+ for i in imapd ipop3d; do
+ umask 077
+ PEM1=`/bin/mktemp ${T}/openssl.XXXXXX`
+ PEM2=`/bin/mktemp ${T}/openssl.XXXXXX`
+ /usr/bin/openssl req -newkey rsa:1024 -keyout $$PEM1 \
+ -nodes -x509 -days 365 -out $$PEM2 << EOF
+--
+SomeState
+SomeCity
+SomeOrganization
+SomeOrganizationalUnit
+localhost.localdomain
+root@localhost.localdomain
+EOF
+
+ cat $$PEM1 > ${i}.pem
+ echo "" >> ${i}.pem
+ cat $$PEM2 >> ${i}.pem
+ rm $$PEM1 $$PEM2
+ umask 022
+ done
+ else
+ yes | make lnp SSLTYPE=none || die
+ fi
+}
+
+src_install() {
+ into /usr
+ dosbin imapd/imapd ipopd/ipop?d dmail/dmail tmail/tmail
+ dobin mailutil/mailutil mlock/mlock mtest/mtest
+
+ if use ssl; then
+ dodir /etc/ssl/certs
+ mv imapd.pem ${D}/etc/ssl/certs
+ mv ipop3d.pem ${D}/etc/ssl/certs
+ fi
+
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ doman src/ipopd/ipopd.8c src/imapd/imapd.8c
+ doman src/dmail/dmail.1 src/tmail/tmail.1 src/mailutil/mailutil.1
+
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+
+ # gentoo config stuff
+ insinto /etc/pam.d
+ newins ${FILESDIR}/uw-imap.pam-system-auth imap
+ newins ${FILESDIR}/uw-imap.pam-system-auth pop
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/uw-imap.xinetd imap
+ newins ${FILESDIR}/uw-ipop2.xinetd ipop2
+ newins ${FILESDIR}/uw-ipop3.xinetd ipop3
+ newins ${FILESDIR}/uw-ipop3s.xinetd ipop3s
+ newins ${FILESDIR}/uw-imaps.xinetd imaps
+}
diff --git a/net-mail/uw-imap/uw-imap-2002e.ebuild b/net-mail/uw-imap/uw-imap-2002e.ebuild
index 957c38895f78..393f9915a8b9 100644
--- a/net-mail/uw-imap/uw-imap-2002e.ebuild
+++ b/net-mail/uw-imap/uw-imap-2002e.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2002e.ebuild,v 1.1 2003/09/11 21:16:10 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2002e.ebuild,v 1.2 2003/10/26 06:05:30 robbat2 Exp $
MY_P=imap-${PV}
S=${WORKDIR}/${MY_P}
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.washington.edu/imap/"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha"
+KEYWORDS="x86 ~sparc ~ppc ~hppa ~alpha"
IUSE="ssl mbox pic"
PROVIDE="virtual/imapd"