summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-13 19:56:15 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-13 19:56:15 +0000
commitaddd042f3bf5e264d87d52d1215e3a8c2b84b020 (patch)
treeacfcb2afbc0ca05b80478b3a88c1be9ed99c45b2 /net-misc/ajaxterm/ajaxterm-0.10.ebuild
parentAdded ~x86-fbsd keyword. (diff)
downloadhistorical-addd042f3bf5e264d87d52d1215e3a8c2b84b020.tar.gz
historical-addd042f3bf5e264d87d52d1215e3a8c2b84b020.tar.bz2
historical-addd042f3bf5e264d87d52d1215e3a8c2b84b020.zip
version bump thanks to Benoit GANNE <benoit.ganne@gmail.com> in bug 158053
Package-Manager: portage-2.1.2_rc3-r4
Diffstat (limited to 'net-misc/ajaxterm/ajaxterm-0.10.ebuild')
-rw-r--r--net-misc/ajaxterm/ajaxterm-0.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/ajaxterm/ajaxterm-0.10.ebuild b/net-misc/ajaxterm/ajaxterm-0.10.ebuild
new file mode 100644
index 000000000000..f6ae97208492
--- /dev/null
+++ b/net-misc/ajaxterm/ajaxterm-0.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ajaxterm/ajaxterm-0.10.ebuild,v 1.1 2006/12/13 19:56:15 genstef Exp $
+
+MY_P=Ajaxterm-${PV}
+DESCRIPTION="Ajaxterm is a web based terminal"
+HOMEPAGE="http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm"
+SRC_URI="http://antony.lesuisse.org/qweb/files/${MY_P}.tar.gz"
+
+LICENSE="public-domain LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.0"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # baselayout's start-stop-daemon wrapper does not allow shell scripts
+ sed -i -e "s: -- :\0/usr/share/ajaxterm/ajaxterm.py :" \
+ -e "s:\(DAEMON=%(bin)s/\)ajaxterm:\1python:" configure.initd.gentoo
+
+ ./configure --prefix=/usr || die "./configure failed"
+}
+
+src_install() {
+ dodir /etc/init.d
+ sed -i -e "s:\"/usr:\"${D}/usr:" \
+ -e "s:\"/etc:\"${D}/etc:" \
+ -e "s:/usr/man:/usr/share/man:" Makefile
+ emake install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "For remote access, it is strongly recommended to use https SSL/TLS"
+ ewarn "On the website is a config for apache web server using mod_proxy"
+}