summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-25 21:50:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-25 21:50:38 +0000
commit02dcbbc50ad6af9cc2892501c2b634090239d000 (patch)
tree4a96e01c1cd9e146ed3d02dc4f85f3a3ea48c6c4 /net-misc/clockspeed/clockspeed-0.62-r4.ebuild
parentStable on hppa. (diff)
downloadhistorical-02dcbbc50ad6af9cc2892501c2b634090239d000.tar.gz
historical-02dcbbc50ad6af9cc2892501c2b634090239d000.tar.bz2
historical-02dcbbc50ad6af9cc2892501c2b634090239d000.zip
Bug #114251, revision bump with updated leapsecs.dat for the leap second at the end of 2005. Also did minor QA cleanups.
Package-Manager: portage-2.1_rc2
Diffstat (limited to 'net-misc/clockspeed/clockspeed-0.62-r4.ebuild')
-rw-r--r--net-misc/clockspeed/clockspeed-0.62-r4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/clockspeed/clockspeed-0.62-r4.ebuild b/net-misc/clockspeed/clockspeed-0.62-r4.ebuild
new file mode 100644
index 000000000000..9fb40c50b4ba
--- /dev/null
+++ b/net-misc/clockspeed/clockspeed-0.62-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clockspeed/clockspeed-0.62-r4.ebuild,v 1.1 2006/05/25 21:50:38 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A simple Network Time Protocol (NTP) client"
+HOMEPAGE="http://cr.yp.to/clockspeed.html"
+SRC_URI="http://cr.yp.to/clockspeed/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="static selinux"
+
+DEPEND="sys-apps/groff"
+RDEPEND=" selinux? ( sec-policy/selinux-clockspeed )"
+
+# this is the trailing part of the name for the latest leapseconds file.
+LEAPSECONDS_DATE="20060525"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ echo "$(tc-getCC) ${CFLAGS} ${ASFLAGS}" > conf-cc
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ dobin clockspeed clockadd clockview sntpclock taiclock taiclockd || die "dobin"
+ dosbin "${FILESDIR}"/ntpclockset || die "dosbin"
+
+ doman *.[13]
+ dodoc BLURB CHANGES INSTALL README THANKS TODO
+
+ insinto /var/lib/clockspeed
+ doins "${FILESDIR}"/leapsecs.dat.20060525
+}