summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-04-04 14:13:08 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-04-04 14:13:08 +0000
commita2ca790e2f93d2cf1a54b888e9db1848f76a6096 (patch)
treebed8f8df5f5ca519b128e512749748a9c64523f8 /net-misc/curl/curl-7.18.1.ebuild
parentundo - should not have done last commit (diff)
downloadhistorical-a2ca790e2f93d2cf1a54b888e9db1848f76a6096.tar.gz
historical-a2ca790e2f93d2cf1a54b888e9db1848f76a6096.tar.bz2
historical-a2ca790e2f93d2cf1a54b888e9db1848f76a6096.zip
correct compile fault with heimdal as a gssapi provider - thanks to Doug in bug #216096
Package-Manager: portage-2.1.4.4 RepoMan-Options: --force
Diffstat (limited to 'net-misc/curl/curl-7.18.1.ebuild')
-rw-r--r--net-misc/curl/curl-7.18.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-misc/curl/curl-7.18.1.ebuild b/net-misc/curl/curl-7.18.1.ebuild
index 97649e36b1fc..2ba76a957650 100644
--- a/net-misc/curl/curl-7.18.1.ebuild
+++ b/net-misc/curl/curl-7.18.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.18.1.ebuild,v 1.2 2008/04/02 10:54:54 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.18.1.ebuild,v 1.3 2008/04/04 14:13:08 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -45,6 +45,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
+ # below: bug #216096
+ sed -i -e 's:gssapi/gssapi.h:gssapi/gssapi_generic.h:g' configure.ac
eautoreconf
}
@@ -91,6 +93,7 @@ src_compile() {
fi
econf ${myconf} || die 'configure failed'
+
emake || die "install failed for current version"
}