summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-02-25 20:55:25 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-02-25 20:55:25 +0000
commit419503878a279018183d6080a5d2158860bd9a76 (patch)
treed1e9380ade906fc9aff0a920efd9dbfe1a0064df /net-misc/dhcdbd/dhcdbd-3.0.ebuild
parentamd64 stable, bug #259578 (diff)
downloadhistorical-419503878a279018183d6080a5d2158860bd9a76.tar.gz
historical-419503878a279018183d6080a5d2158860bd9a76.tar.bz2
historical-419503878a279018183d6080a5d2158860bd9a76.zip
Fix compile bug when using FORTIFY_SOURCE: open with O_CREAT in second argument
needs 3 arguments, bug #232084 Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'net-misc/dhcdbd/dhcdbd-3.0.ebuild')
-rw-r--r--net-misc/dhcdbd/dhcdbd-3.0.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-misc/dhcdbd/dhcdbd-3.0.ebuild b/net-misc/dhcdbd/dhcdbd-3.0.ebuild
index ce5473f8723a..661f79b15490 100644
--- a/net-misc/dhcdbd/dhcdbd-3.0.ebuild
+++ b/net-misc/dhcdbd/dhcdbd-3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcdbd/dhcdbd-3.0.ebuild,v 1.5 2008/02/29 03:12:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcdbd/dhcdbd-3.0.ebuild,v 1.6 2009/02/25 20:55:25 rbu Exp $
inherit eutils
@@ -16,23 +16,24 @@ IUSE="debug"
DEPEND="sys-apps/dbus
>=net-misc/dhcp-3.0.3-r7"
+RDEPEND=${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-2.5-fixes.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.5-fixes.patch
# Create a pidfile immediately after daemonizing so we're more robust
# with baselayout-2.
- epatch ${FILESDIR}/${PN}-3.0-daemon.patch
+ epatch "${FILESDIR}"/${PN}-3.0-daemon.patch
# We don't and won't have dbus snapshots in the tree
- epatch ${FILESDIR}/${PN}-3.0-dbus.patch
+ epatch "${FILESDIR}"/${PN}-3.0-dbus.patch
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc README include/dhcp_options.h
- newinitd ${FILESDIR}/dhcdbd.init dhcdbd
- newconfd ${FILESDIR}/dhcdbd.confd dhcdbd
+ newinitd "${FILESDIR}"/dhcdbd.init dhcdbd
+ newconfd "${FILESDIR}"/dhcdbd.confd dhcdbd
}
pkg_postinst() {