summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-16 03:47:27 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-16 03:47:27 +0000
commit00f978866c5d7accaa4610129b8d8f7209f19607 (patch)
tree49ceb1d9b970a3247fae8b04eb6017c8cacaaea5 /net-misc/dhcp
parentUpdated DEPEND to include sgml dtd version 3.1 (diff)
downloadhistorical-00f978866c5d7accaa4610129b8d8f7209f19607.tar.gz
historical-00f978866c5d7accaa4610129b8d8f7209f19607.tar.bz2
historical-00f978866c5d7accaa4610129b8d8f7209f19607.zip
version bump, marked unstable
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/ChangeLog10
-rw-r--r--net-misc/dhcp/dhcp-3.0_p2.ebuild91
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_p21
3 files changed, 100 insertions, 2 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index 32ec49b1c7e9..c74555cb6a48 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.11 2002/12/29 23:55:38 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.12 2003/01/16 03:47:27 lostlogic Exp $
+
+*dhcp-3.0_p2 (15 Jan 2003)
+
+ 15 Jan 2003; Brandon Low <lostlogic@gentoo.org> dhcp-3.0_p2.ebuild:
+ Version update, and update the ebuild to automatically assign
+ it's source name.
*dhcp-3.0_p1 (29 Dec 2002)
@@ -21,7 +27,7 @@
files/dhcp.rc7, digest-dhcp-3.0-r3:
Update ebuild to touch dhcp.leases, fix config and init.d files
- to work more sanetly.
+ to work more sanely.
*dhcp-3.0-r2 (16 Jun 2002)
diff --git a/net-misc/dhcp/dhcp-3.0_p2.ebuild b/net-misc/dhcp/dhcp-3.0_p2.ebuild
new file mode 100644
index 000000000000..0c749fcfc9ac
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0_p2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_p2.ebuild,v 1.1 2003/01/16 03:47:27 lostlogic Exp $
+
+#This should be fairly consistant now, unless we have any _pre releases...
+MYP="${P/_p/pl}"
+
+S=${WORKDIR}/${MYP}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MYP}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+LICENSE="isc-dhcp"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+SLOT="0"
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/dhclient.c-3.0-dw-cli-fix.patch || die
+
+ cd ${S}/includes
+ cat <<- END >> site.h
+#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+#define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+#define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+ cat <<- END > site.conf
+CC = gcc ${CFLAGS}
+ETC = /etc/dhcp
+VARDB = /var/lib/dhcp
+ADMMANDIR = /usr/share/man/man8
+FFMANDIR = /usr/share/man/man5
+LIBMANDIR = /usr/share/man/man3
+END
+ ./configure --with-nsupdate || die
+ emake || die
+}
+
+src_install() {
+ dodir /var/lib/dhcp
+ touch ${D}/var/lib/dhcp/dhclient.leases
+ touch ${D}/var/lib/dhcp/dhcpd.leases
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.dhcpd dhcp
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp.rc7 dhcp
+}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_p2 b/net-misc/dhcp/files/digest-dhcp-3.0_p2
new file mode 100644
index 000000000000..69ed0169648a
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0_p2
@@ -0,0 +1 @@
+MD5 2cb5db7a0c23deaef4724b5fc3f9a869 dhcp-3.0pl2.tar.gz 865196