summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-10-10 19:49:32 +0000
committerPeter Volkov <pva@gentoo.org>2011-10-10 19:49:32 +0000
commit6808f7356cd99bdf143e6b3af12711605343f896 (patch)
treea07c6c27167bbc99d0889fd5bae62ae37690f780 /net-misc/ipv6calc/ipv6calc-0.92.0.ebuild
parentVersion bump. (diff)
downloadhistorical-6808f7356cd99bdf143e6b3af12711605343f896.tar.gz
historical-6808f7356cd99bdf143e6b3af12711605343f896.tar.bz2
historical-6808f7356cd99bdf143e6b3af12711605343f896.zip
Version bump.
Package-Manager: portage-2.1.10.20/cvs/Linux x86_64
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-0.92.0.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.92.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-0.92.0.ebuild b/net-misc/ipv6calc/ipv6calc-0.92.0.ebuild
new file mode 100644
index 000000000000..552796f35061
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.92.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.92.0.ebuild,v 1.1 2011/10/10 19:49:32 pva Exp $
+
+EAPI="4"
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="geoip? ( >=dev-libs/geoip-1.4.7 )"
+
+src_prepare() {
+ # Tests don't work, will be fixed next release
+ echo true > ipv6calc/test_showinfo.sh || die
+ ht_fix_file configure
+}
+
+src_configure() {
+ econf $(use_enable geoip)
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}